summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-28 16:43:19 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-28 16:43:19 +0000
commit12398c8494a8c9cda0ebd2de391797ffe1073295 (patch)
tree8976f89f8e3d084fd2e6108fae1957cb779cd1cb /net-misc/mosh/mosh-9999.ebuild
parentalpha/ia64/s390/sh/sparc stable wrt #414929 (diff)
downloadhistorical-12398c8494a8c9cda0ebd2de391797ffe1073295.tar.gz
historical-12398c8494a8c9cda0ebd2de391797ffe1073295.tar.bz2
historical-12398c8494a8c9cda0ebd2de391797ffe1073295.zip
make mosh-hardening optional for slow machines (add USE mosh-hardening, bug 417919, thanks fling)
Package-Manager: portage-2.1.10.63/cvs/Linux x86_64
Diffstat (limited to 'net-misc/mosh/mosh-9999.ebuild')
-rw-r--r--net-misc/mosh/mosh-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-misc/mosh/mosh-9999.ebuild b/net-misc/mosh/mosh-9999.ebuild
index 0d894369ecdf..5b049f1f1873 100644
--- a/net-misc/mosh/mosh-9999.ebuild
+++ b/net-misc/mosh/mosh-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-9999.ebuild,v 1.10 2012/05/27 06:21:28 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-9999.ebuild,v 1.11 2012/05/28 16:43:19 xmw Exp $
EAPI=4
EGIT_REPO_URI="https://github.com/keithw/mosh.git"
@@ -13,7 +13,7 @@ HOMEPAGE="http://mosh.mit.edu"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="bash-completion +client examples +server ufw +utempter"
+IUSE="bash-completion +client examples +mosh-hardening +server ufw +utempter"
REQUIRED_USE="|| ( client server )
examples? ( client )"
@@ -24,6 +24,7 @@ RDEPEND="dev-libs/protobuf
dev-perl/IO-Tty )
utempter? ( sys-libs/libutempter )"
DEPEND="${RDEPEND}
+ dev-vcs/git[curl]
virtual/pkgconfig"
src_prepare() {
@@ -38,6 +39,7 @@ src_configure() {
$(use_enable server) \
$(use_enable examples) \
$(use_enable ufw) \
+ $(use_enable mosh-hardening hardening) \
$(use_with utempter)
}