summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-23 22:27:31 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-23 22:27:31 +0000
commit3bfeef48b9df4619a1d30085ad7c835092c030d2 (patch)
treeda0b2c3a40e8463799c1b934f585cf95e41c1210 /net-misc/mosh/mosh-9999.ebuild
parentRemove encode and wav USE flags. (diff)
downloadhistorical-3bfeef48b9df4619a1d30085ad7c835092c030d2.tar.gz
historical-3bfeef48b9df4619a1d30085ad7c835092c030d2.tar.bz2
historical-3bfeef48b9df4619a1d30085ad7c835092c030d2.zip
Version bump, new USE flags.
Package-Manager: portage-2.1.10.62/cvs/Linux x86_64
Diffstat (limited to 'net-misc/mosh/mosh-9999.ebuild')
-rw-r--r--net-misc/mosh/mosh-9999.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/net-misc/mosh/mosh-9999.ebuild b/net-misc/mosh/mosh-9999.ebuild
index 5cfdad25fe1d..960d28ecc9f4 100644
--- a/net-misc/mosh/mosh-9999.ebuild
+++ b/net-misc/mosh/mosh-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-9999.ebuild,v 1.8 2012/05/19 08:05:36 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-9999.ebuild,v 1.9 2012/05/23 22:27:31 xmw Exp $
EAPI=4
EGIT_REPO_URI="https://github.com/keithw/mosh.git"
@@ -13,7 +13,7 @@ HOMEPAGE="http://mosh.mit.edu"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="+client examples +server +utempter"
+IUSE="bash-completion +client examples +server ufw +utempter"
REQUIRED_USE="|| ( client server )
examples? ( client )"
@@ -32,12 +32,26 @@ src_prepare() {
src_configure() {
econf \
+ $(use_enable test tests) \
+ $(use_enable bash-completion completion) \
$(use_enable client) \
$(use_enable server) \
$(use_enable examples) \
+ $(use_enable ufw) \
$(use_with utempter)
}
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ einfo "running test encrypt-decrypt"
+ ./src/tests/encrypt-decrypt -q || die
+ einfo "running test ocb-aes"
+ ./src/tests/ocb-aes -q || die
+}
+
src_install() {
default