summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-01-07 18:53:42 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-01-07 18:53:42 +0000
commitc4cc493eeb7c15092ced94aabd3a075106995d06 (patch)
tree3ef3badef7d3fa0e0449ebbc678d7976fbb53853 /net-misc/ntp
parentInitial release. (diff)
downloadhistorical-c4cc493eeb7c15092ced94aabd3a075106995d06.tar.gz
historical-c4cc493eeb7c15092ced94aabd3a075106995d06.tar.bz2
historical-c4cc493eeb7c15092ced94aabd3a075106995d06.zip
New version.
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/files/digest-ntp-4.1.721
-rw-r--r--net-misc/ntp/ntp-4.1.72.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/ntp/files/digest-ntp-4.1.72 b/net-misc/ntp/files/digest-ntp-4.1.72
new file mode 100644
index 000000000000..dcbe4c0b8a8b
--- /dev/null
+++ b/net-misc/ntp/files/digest-ntp-4.1.72
@@ -0,0 +1 @@
+MD5 de9ed6a28f4c4ffea932a49db5b745fa ntp-4.1.72.tar.gz 2531328
diff --git a/net-misc/ntp/ntp-4.1.72.ebuild b/net-misc/ntp/ntp-4.1.72.ebuild
new file mode 100644
index 000000000000..5e4a8e06e241
--- /dev/null
+++ b/net-misc/ntp/ntp-4.1.72.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Terry Chan <tchan@enteract.com>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.72.ebuild,v 1.1 2002/01/07 18:53:42 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network Time Protocol suite/programs"
+SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/${P}.tar.gz"
+HOMEPAGE="http://www.ntp.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1"
+
+src_compile() {
+ cp configure configure.orig
+ sed -e "s:-Wpointer-arith::" configure.orig > configure
+ LDFLAGS="$LDFLAGS -lncurses"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --host=${CHOST} --build=${CHOST} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+
+ dodoc ChangeLog INSTALL NEWS README TODO WHERE-TO-START
+ insinto /usr/share/doc/${PF}/html ; doins html/*.htm
+ insinto /usr/share/doc/${PF}/html/hints ; doins html/hints/*
+ insinto /usr/share/doc/${PF}/html/pic ; doins html/pic/*
+
+ insinto /usr/share/ntp ; doins scripts/*
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/ntpd.rc6 ntpd
+}