summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-01-31 21:51:52 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-01-31 21:51:52 +0000
commitf9f5fa181d8af9484dbf8421858d47a3afc7ff63 (patch)
treef2e14107704a1cdf2293bc13db83e79210cc1c65 /net-misc/openvpn/openvpn-1.3.2.ebuild
parentnew package. x86 masked. fixes #10556 (diff)
downloadhistorical-f9f5fa181d8af9484dbf8421858d47a3afc7ff63.tar.gz
historical-f9f5fa181d8af9484dbf8421858d47a3afc7ff63.tar.bz2
historical-f9f5fa181d8af9484dbf8421858d47a3afc7ff63.zip
new version. x86 masked. fixes #11574
Diffstat (limited to 'net-misc/openvpn/openvpn-1.3.2.ebuild')
-rw-r--r--net-misc/openvpn/openvpn-1.3.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/openvpn/openvpn-1.3.2.ebuild b/net-misc/openvpn/openvpn-1.3.2.ebuild
new file mode 100644
index 000000000000..e4c583e2d6a8
--- /dev/null
+++ b/net-misc/openvpn/openvpn-1.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.3.2.ebuild,v 1.1 2003/01/31 21:51:52 rphillips Exp $
+
+IUSE="ssl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/openvpn/${P}.tar.gz"
+HOMEPAGE="http://openvpn.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND=">=dev-libs/lzo-1.07
+ virtual/linux-sources
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+
+ local myconf
+
+ use ssl || myconf='--disable-ssl --disable-crypto'
+
+ ./autogen.sh || die
+ econf || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING CHANGES INSTALL PORTS README
+
+}