summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-18 21:21:40 +0000
committerMike Frysinger <vapier@gentoo.org>2012-08-18 21:21:40 +0000
commit6106d968d516a8cc3c3a96f683e349690951da91 (patch)
tree3b626023de6441dcea1bd18e13d9e4df5e847791 /net-misc/pps-tools/files
parentVersion bump. Remove old. (diff)
downloadhistorical-6106d968d516a8cc3c3a96f683e349690951da91.tar.gz
historical-6106d968d516a8cc3c3a96f683e349690951da91.tar.bz2
historical-6106d968d516a8cc3c3a96f683e349690951da91.zip
Update snapshot #424443 by Gary E. Miller.
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'net-misc/pps-tools/files')
-rw-r--r--net-misc/pps-tools/files/pps-tools-0.0.20120407-build.patch53
-rw-r--r--net-misc/pps-tools/files/pps-tools-0.0.20120407-install.patch28
2 files changed, 81 insertions, 0 deletions
diff --git a/net-misc/pps-tools/files/pps-tools-0.0.20120407-build.patch b/net-misc/pps-tools/files/pps-tools-0.0.20120407-build.patch
new file mode 100644
index 000000000000..5a27bb65184b
--- /dev/null
+++ b/net-misc/pps-tools/files/pps-tools-0.0.20120407-build.patch
@@ -0,0 +1,53 @@
+From f4133df52856adfe9ffa2152f0e449f2f8adb49d Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 18 Aug 2012 17:04:43 -0400
+Subject: [PATCH] fix up makefile
+
+Make sure we respect CFLAGS/CPPFLAGS properly.
+
+Also fix up the depend include so we get reproducible behavior --
+the depend file is generated & included first, and we don't get
+weird behavior when we run:
+ git clean -x -d
+ make
+ make
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 13 +++++--------
+ 1 file changed, 5 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0fb84b4..a07156f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,8 @@
+ TARGETS = ppstest ppsctl ppswatch
+
+-CFLAGS += -Wall -O2 -D_GNU_SOURCE
+-CFLAGS += -I .
+-CFLAGS += -ggdb
+-CFLAGS += -D__N_PPS=18
++CFLAGS ?= -O2 -ggdb
++CFLAGS += -Wall
++CPPFLAGS += -D_GNU_SOURCE -I. -D__N_PPS=18
+
+ # -- Actions section --
+
+@@ -12,11 +11,9 @@ CFLAGS += -D__N_PPS=18
+ all : .depend $(TARGETS)
+
+ .depend depend dep :
+- $(CC) $(CFLAGS) -M $(TARGETS:=.c) > .depend
++ $(CC) $(CPPFLAGS) $(CFLAGS) -M $(TARGETS:=.c) > .depend
+
+-ifeq (.depend,$(wildcard .depend))
+-include .depend
+-endif
++-include .depend
+
+ install : all
+ install -m 755 -t $(DESTDIR)/usr/bin ppsfind $(TARGETS)
+--
+1.7.9.7
+
diff --git a/net-misc/pps-tools/files/pps-tools-0.0.20120407-install.patch b/net-misc/pps-tools/files/pps-tools-0.0.20120407-install.patch
new file mode 100644
index 000000000000..e268d6622a94
--- /dev/null
+++ b/net-misc/pps-tools/files/pps-tools-0.0.20120407-install.patch
@@ -0,0 +1,28 @@
+From 0b3a849153ffb42fb22fe42dc2b9e59ca23cec8c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 18 Aug 2012 17:15:19 -0400
+Subject: [PATCH] fix DESTDIR installs
+
+Make sure the dirs we install into exist first:
+ make install DESTDIR=$PWD/foo
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile b/Makefile
+index a07156f..bebcce7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,6 +16,7 @@ all : .depend $(TARGETS)
+ -include .depend
+
+ install : all
++ mkdir -p -m 755 $(DESTDIR)/usr/bin $(DESTDIR)/usr/include/sys
+ install -m 755 -t $(DESTDIR)/usr/bin ppsfind $(TARGETS)
+ install -m 644 -t $(DESTDIR)/usr/include/sys timepps.h
+
+--
+1.7.9.7
+