summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-03-07 16:03:56 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-03-07 16:03:56 +0000
commit861ad0c7a464b3d01b175531bd25987e2206a470 (patch)
tree40f083520f1ecb6a495d80afa8478553e368d7b6 /net-misc/pump/pump-0.8.24-r3.ebuild
parentMigrate to EAPI 2. (diff)
downloadhistorical-861ad0c7a464b3d01b175531bd25987e2206a470.tar.gz
historical-861ad0c7a464b3d01b175531bd25987e2206a470.tar.bz2
historical-861ad0c7a464b3d01b175531bd25987e2206a470.zip
Revision bump: fix bug #260929 (static linking against popt), respect LDFLAGS.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'net-misc/pump/pump-0.8.24-r3.ebuild')
-rw-r--r--net-misc/pump/pump-0.8.24-r3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/pump/pump-0.8.24-r3.ebuild b/net-misc/pump/pump-0.8.24-r3.ebuild
new file mode 100644
index 000000000000..6389c88ecc63
--- /dev/null
+++ b/net-misc/pump/pump-0.8.24-r3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.24-r3.ebuild,v 1.1 2009/03/07 16:03:56 nelchael Exp $
+
+inherit eutils toolchain-funcs
+
+PATCHLEVEL="5"
+
+DESCRIPTION="This is the DHCP/BOOTP client written by RedHat"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/p/pump/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/p/${PN}/${PN}_${PV}-${PATCHLEVEL}.diff.gz
+ mirror://gentoo/${P}-1-patches.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/popt-1.5"
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apply Debians pump patchset - they fix things good :)
+ epatch "${WORKDIR}/${PN}_${PV}-${PATCHLEVEL}.diff"
+
+ for i in "${WORKDIR}/${PV}/"*; do
+ epatch "${i}"
+ done
+
+ # Only install specific po files if LINGUAS is set
+ if [[ -n ${LINGUAS} ]]; then
+ cd po
+ local p
+ for l in $(ls *.po) ; do
+ [[ " ${LINGUAS} " != *" ${l%%.po} "* ]] && rm -f "${l}"
+ done
+ fi
+}
+
+src_compile() {
+ make CC="$(tc-getCC)" DEB_CFLAGS="-fPIC ${CFLAGS}" pump || die
+}
+
+src_install() {
+ into /
+ dosbin pump || die
+
+ doman pump.8
+ dodoc CREDITS
+
+ into /usr
+ dolib.a libpump.a || die
+ insinto /usr/include
+ doins pump.h || die
+
+ make -C po install datadir="${D}/usr/share/"
+}