summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2013-03-06 21:37:55 +0000
committerChristian Birchinger <joker@gentoo.org>2013-03-06 21:37:55 +0000
commitabbc3031b75efad666a722afc26c628554bc3716 (patch)
tree2bcb9cc33c1594b89f92720df9556febba476001 /net-misc/r8168/r8168-8.035.00-r1.ebuild
parentFix test execution wrt bug#459174. Thanks to Alphat-PC for the patch. (diff)
downloadhistorical-abbc3031b75efad666a722afc26c628554bc3716.tar.gz
historical-abbc3031b75efad666a722afc26c628554bc3716.tar.bz2
historical-abbc3031b75efad666a722afc26c628554bc3716.zip
Added a patch for Linux 3.8 support
Package-Manager: portage-2.1.11.52/cvs/Linux x86_64 Manifest-Sign-Key: 0x0151863A67652900!
Diffstat (limited to 'net-misc/r8168/r8168-8.035.00-r1.ebuild')
-rw-r--r--net-misc/r8168/r8168-8.035.00-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/r8168/r8168-8.035.00-r1.ebuild b/net-misc/r8168/r8168-8.035.00-r1.ebuild
new file mode 100644
index 000000000000..b9d74d7eda77
--- /dev/null
+++ b/net-misc/r8168/r8168-8.035.00-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/r8168/r8168-8.035.00-r1.ebuild,v 1.1 2013/03/06 21:37:48 joker Exp $
+
+EAPI=4
+
+inherit linux-mod eutils
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="http://www.realtek.com.tw"
+SRC_URI="http://r8168.googlecode.com/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+CONFIG_CHECK="!R8169"
+
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build-3.8.patch"
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+}