summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-04-10 09:57:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-04-10 09:57:25 +0000
commita392781c51ad5ec8994fce63e70ee383c7552f44 (patch)
treea21c503b08d47415e7feffb995c4dc1d86048949 /net-misc/rdate/rdate-1.4-r3.ebuild
parentAdd dependency for dev-libs/libxml2. (diff)
downloadhistorical-a392781c51ad5ec8994fce63e70ee383c7552f44.tar.gz
historical-a392781c51ad5ec8994fce63e70ee383c7552f44.tar.bz2
historical-a392781c51ad5ec8994fce63e70ee383c7552f44.zip
Bug #173218, clean up init.d script timeout, patch thanks to Yang Zhao <yangman@gmail.com>.
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'net-misc/rdate/rdate-1.4-r3.ebuild')
-rw-r--r--net-misc/rdate/rdate-1.4-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/rdate/rdate-1.4-r3.ebuild b/net-misc/rdate/rdate-1.4-r3.ebuild
new file mode 100644
index 000000000000..c111d8e4247d
--- /dev/null
+++ b/net-misc/rdate/rdate-1.4-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdate/rdate-1.4-r3.ebuild,v 1.1 2007/04/10 09:57:25 robbat2 Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="use TCP or UDP to retrieve the current time of another machine"
+HOMEPAGE="http://www.freshmeat.net/projects/rdate/"
+SRC_URI="ftp://people.redhat.com/sopwith/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ use ipv6 && append-flags "-DINET6"
+ emake RCFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install(){
+ make prefix="${D}/usr" install || die "make install failed"
+ newinitd ${FILESDIR}/rdate-initd-1.4-r3 rdate
+ newconfd ${FILESDIR}/rdate-confd rdate
+}