summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-07-18 02:53:57 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-07-18 02:53:57 +0000
commitccdf29571f6854daae4049335a16e328836ef5aa (patch)
treeae53b3446f63a2181572e844343e5435aa32e559 /net-misc/unison/unison-2.9.1.ebuild
parentNew ebuild of autofs with OpenLDAP 2.x support. Also proper setting of (diff)
downloadhistorical-ccdf29571f6854daae4049335a16e328836ef5aa.tar.gz
historical-ccdf29571f6854daae4049335a16e328836ef5aa.tar.bz2
historical-ccdf29571f6854daae4049335a16e328836ef5aa.zip
new package unison: bidirectional cross-platform file synchronization
Diffstat (limited to 'net-misc/unison/unison-2.9.1.ebuild')
-rw-r--r--net-misc/unison/unison-2.9.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/unison/unison-2.9.1.ebuild b/net-misc/unison/unison-2.9.1.ebuild
new file mode 100644
index 000000000000..3bde7e9c5e19
--- /dev/null
+++ b/net-misc/unison/unison-2.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.9.1.ebuild,v 1.1 2002/07/18 02:53:57 george Exp $
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=dev-lang/ocaml-3.04
+ gtk? ( >=dev-ml/lablgtk-1.2.3 )"
+RDEPEND="gtk? ( >=x11-libs/gtk+-1.2.10 )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/stable/${P}/src.tar.gz"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ local myconf
+
+ if [ `use gtk` ]; then
+ myconf="$myconf UISTYLE=gtk"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ make $myconf CFLAGS="" || die
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ dobin unison
+ dodoc BUGS.txt CONTRIB COPYING INSTALL NEWS \
+ README ROADMAP.txt TODO.txt
+}