summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2003-10-18 02:04:54 +0000
committerChuck Short <zul@gentoo.org>2003-10-18 02:04:54 +0000
commita590a1c16c78e4034b4654b61ed22afe88f2e0ce (patch)
treecf1b6cd820edbdd4be489f94b1745ef844607723 /net-misc/vtun/vtun-2.6.ebuild
parentVersion bump. (diff)
downloadhistorical-a590a1c16c78e4034b4654b61ed22afe88f2e0ce.tar.gz
historical-a590a1c16c78e4034b4654b61ed22afe88f2e0ce.tar.bz2
historical-a590a1c16c78e4034b4654b61ed22afe88f2e0ce.zip
Version bump.
Diffstat (limited to 'net-misc/vtun/vtun-2.6.ebuild')
-rw-r--r--net-misc/vtun/vtun-2.6.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/vtun/vtun-2.6.ebuild b/net-misc/vtun/vtun-2.6.ebuild
new file mode 100644
index 000000000000..fe38f12016da
--- /dev/null
+++ b/net-misc/vtun/vtun-2.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/vtun-2.6.ebuild,v 1.1 2003/10/18 02:04:50 zul Exp $
+
+IUSE="ssl"
+
+S=${WORKDIR}/vtun
+DESCRIPTION="Create virtual tunnels over TCP/IP networks with traffic shaping, encryption, and compression"
+SRC_URI="mirror://sourceforge/vtun/${P}.tar.gz"
+HOMEPAGE="http://vtun.sourceforge.net/"
+KEYWORDS="x86 sparc "
+LICENSE="GPL-2"
+SLOT="0"
+
+# NOTE: you also need the tun/tap driver compiled into your kernel
+# to do tun/tap tunneling
+DEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ >=dev-libs/lzo-1.07
+ sys-devel/bison
+ ssl? ( >=dev-libs/openssl-0.9.6c )"
+
+src_unpack() {
+ unpack ${A} && cd ${S} || die
+ epatch ${FILESDIR}/${PN}-${PV}-makefile.patch
+}
+
+src_compile() {
+ local use_opts
+ use_opts=""
+ if [ -z "`use ssl`" ]
+ then
+ use_opts="--disable-ssl"
+ fi
+
+ econf ${use_opts} --with-ssl-headers=/usr/include/openssl || die
+
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} prefix=/usr \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ datadir=/usr/share \
+ sysconfdir=/etc \
+ localstatedir=/var/lib \
+ install || die
+
+ dodoc ChangeLog Credits FAQ README README.Setup README.Shaper TODO
+
+ exeinto etc/init.d;
+ newexe ${FILESDIR}/vtun.rc vtun
+
+ insinto etc
+ doins ${FILESDIR}/vtund-start.conf
+}
+
+pkg_postinst () {
+ echo ">>> You will need the Universal TUN/TAP driver compiled into"
+ echo ">>> your kernel or as a module to use the associated tunnel"
+ echo ">>> modes in vtun. 2.2 users will need to download and install"
+ echo ">>> the driver from http://vtun.sourceforge.net/tun"
+}