summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-04-13 20:14:30 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-04-13 20:14:30 +0000
commit099d5628b24ead5af204743502326276764c3e76 (patch)
tree6c41183d50d1953a204feb8f6fae37238b99e6d7 /net-misc/whois/whois-4.6.13.ebuild
parent~amd64 (diff)
downloadhistorical-099d5628b24ead5af204743502326276764c3e76.tar.gz
historical-099d5628b24ead5af204743502326276764c3e76.tar.bz2
historical-099d5628b24ead5af204743502326276764c3e76.zip
Version bumped. Closes 47532
Diffstat (limited to 'net-misc/whois/whois-4.6.13.ebuild')
-rw-r--r--net-misc/whois/whois-4.6.13.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/whois/whois-4.6.13.ebuild b/net-misc/whois/whois-4.6.13.ebuild
new file mode 100644
index 000000000000..2816fda70d3f
--- /dev/null
+++ b/net-misc/whois/whois-4.6.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.6.13.ebuild,v 1.1 2004/04/13 20:14:30 mholzer Exp $
+
+IUSE="nls"
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+SRC_URI="http://www.linux.it/~md/software/${MY_P}.tar.gz"
+HOMEPAGE="http://www.linux.it/~md/software/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips hppa ~ia64 ~alpha ~amd64"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-lang/perl-5"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s/-O2/$CFLAGS/" Makefile
+
+ use nls && ( \
+ cd po
+ sed -i -e "s:/usr/bin/install:install:" Makefile
+ ) || ( \
+ sed -i -e "s:cd po.*::" Makefile
+ )
+
+ epatch ${FILESDIR}/${P}-gentoo-security.patch || die
+}
+
+src_compile() {
+ make || die
+ make mkpasswd || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ use nls && dodir /usr/share/locale
+ make BASEDIR=${D} prefix=/usr mandir=/usr/share/man install || die
+
+ dobin mkpasswd
+ doman mkpasswd.1
+ dodoc README whois.conf debian/changelog debian/copyright
+
+ einfo ""
+ einfo "The example whois.conf is located in /usr/doc/${P}"
+ einfo ""
+}