summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-24 16:11:38 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-24 16:11:38 +0000
commitc4fc14bb7a8a0b27db5c263e2705f61d7f62e19e (patch)
tree976f32821e8884a875cdbf97b71925e2da100635 /net-misc/wput/wput-0.6.1.ebuild
parentx86 stable, bug #211252 (diff)
downloadhistorical-c4fc14bb7a8a0b27db5c263e2705f61d7f62e19e.tar.gz
historical-c4fc14bb7a8a0b27db5c263e2705f61d7f62e19e.tar.bz2
historical-c4fc14bb7a8a0b27db5c263e2705f61d7f62e19e.zip
Version bump, bug #207579
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-misc/wput/wput-0.6.1.ebuild')
-rw-r--r--net-misc/wput/wput-0.6.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/wput/wput-0.6.1.ebuild b/net-misc/wput/wput-0.6.1.ebuild
new file mode 100644
index 000000000000..faa23eb09028
--- /dev/null
+++ b/net-misc/wput/wput-0.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/wput-0.6.1.ebuild,v 1.1 2008/02/24 16:11:37 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="A tiny program that looks like wget and is designed to upload files or whole directories to remote ftp-servers"
+HOMEPAGE="http://wput.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug nls ssl"
+
+RDEPEND="ssl? ( net-libs/gnutls )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.6-gentoo.diff"
+ # Fix bug 126828
+ epatch "${FILESDIR}/wput-0.6-respectldflags.patch"
+}
+
+src_compile() {
+ local myconf
+ use debug && myconf="--enable-memdbg=yes" || myconf="--enable-g-switch=no"
+ econf ${myconf} \
+ $(use_enable nls) \
+ $(use_with ssl) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog INSTALL TODO
+}