summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-08-21 19:11:51 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-08-21 19:11:51 +0000
commit322ebc55319114a5a392bcef34abd5d3d404cc14 (patch)
treefe46543a03be263d718cf588eca64217eaad581d /net-misc
parentmove the sshd -t test after key generation, and update key generation to retu... (diff)
downloadhistorical-322ebc55319114a5a392bcef34abd5d3d404cc14.tar.gz
historical-322ebc55319114a5a392bcef34abd5d3d404cc14.tar.bz2
historical-322ebc55319114a5a392bcef34abd5d3d404cc14.zip
bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/files/digest-putty-0.581
-rw-r--r--net-misc/putty/putty-0.58.ebuild60
3 files changed, 67 insertions, 1 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 5f0c1e2b16d7..2289567609a8 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/putty
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.25 2005/08/21 18:21:24 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.26 2005/08/21 19:11:51 taviso Exp $
+
+*putty-0.58 (21 Aug 2005)
+
+ 21 Aug 2005; Tavis Ormandy <taviso@gentoo.org> +putty-0.58.ebuild:
+ bump
21 Aug 2005; Tavis Ormandy <taviso@gentoo.org> putty-0.57.ebuild:
fix #103268
diff --git a/net-misc/putty/files/digest-putty-0.58 b/net-misc/putty/files/digest-putty-0.58
new file mode 100644
index 000000000000..ecabcdfd24ef
--- /dev/null
+++ b/net-misc/putty/files/digest-putty-0.58
@@ -0,0 +1 @@
+MD5 ffb78a7db7e4802896189b2112714a9f putty-0.58.tar.gz 1567268
diff --git a/net-misc/putty/putty-0.58.ebuild b/net-misc/putty/putty-0.58.ebuild
new file mode 100644
index 000000000000..608c9b830718
--- /dev/null
+++ b/net-misc/putty/putty-0.58.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.58.ebuild,v 1.1 2005/08/21 19:11:51 taviso Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="http://the.earth.li/~sgtatham/putty/${PV}/${P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc ~amd64"
+IUSE="doc gtk ipv6"
+
+RDEPEND="gtk? ( =x11-libs/gtk+-1.2* virtual/x11 )"
+DEPEND="${RDEPEND} dev-lang/perl"
+
+src_compile() {
+ use gtk || local targets="puttygen plink pscp psftp"
+ cd ${S}/unix
+
+ append-flags '-I.././' '-I../charset/' '-I../unix/'
+
+ use ipv6 || append-flags '-DNO_IPV6'
+ use gtk && append-flags '`gtk-config --cflags`'
+
+ emake -f Makefile.gtk ${targets:-all} CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ cd ${S}/doc
+ use gtk && doman pterm.1 putty.1 puttytel.1
+ use doc && dohtml *.html
+ dodoc puttydoc.txt
+ doman puttygen.1 plink.1
+
+ cd ${S}/unix
+ use gtk && dobin pterm putty puttytel
+ dobin puttygen plink pscp psftp
+
+ cd ${S}
+ dodoc README README.txt LICENCE CHECKLST.txt LATEST.VER
+
+ prepallman
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ use gtk && {
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ doins ${FILESDIR}/putty.desktop
+ }
+
+ if test ! -c /dev/ptmx; then
+ ewarn
+ ewarn "The pterm application requires kernel UNIX98 PTY support to operate."
+ ewarn
+ fi
+}