summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-01-19 17:23:47 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-01-19 17:23:47 +0000
commit530993cf31f8969dac20f62033ac19b4f61cfbbb (patch)
tree60719856fecc315fbb268fb2470864f776ff98ae /net-misc
parentFix manifest (diff)
downloadhistorical-530993cf31f8969dac20f62033ac19b4f61cfbbb.tar.gz
historical-530993cf31f8969dac20f62033ac19b4f61cfbbb.tar.bz2
historical-530993cf31f8969dac20f62033ac19b4f61cfbbb.zip
Drop old. Fix bug #389635.
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.5.ebuild91
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.7.159-r1.ebuild (renamed from net-misc/spice-gtk/spice-gtk-0.6-r1.ebuild)64
2 files changed, 46 insertions, 109 deletions
diff --git a/net-misc/spice-gtk/spice-gtk-0.5.ebuild b/net-misc/spice-gtk/spice-gtk-0.5.ebuild
deleted file mode 100644
index 792040a98b25..000000000000
--- a/net-misc/spice-gtk/spice-gtk-0.5.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.5.ebuild,v 1.1 2011/02/24 13:46:09 dev-zero Exp $
-
-EAPI=3
-
-inherit python gnome2-utils
-
-PYTHON_DEPEND="python? 2"
-
-DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI."
-HOMEPAGE="http://spice-space.org http://gitorious.org/spice-gtk"
-SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+cairo doc gnome gstreamer introspection kde +pulseaudio python static-libs"
-
-RDEPEND="pulseaudio? ( !gstreamer? ( media-sound/pulseaudio ) )
- gstreamer? ( media-libs/gstreamer )
- >=app-emulation/spice-protocol-0.6.3
- >=x11-libs/pixman-0.17.7
- >=media-libs/celt-0.5.1.1:0.5.1
- dev-libs/openssl
- x11-libs/gtk+:2
- dev-libs/glib:2
- >=x11-libs/cairo-1.2
- virtual/jpeg
- sys-libs/zlib
- introspection? ( dev-libs/gobject-introspection )
- python? ( dev-python/pygtk:2 )
- gnome? ( gnome-base/gconf )"
-DEPEND="${RDEPEND}
- dev-lang/python
- dev-lang/perl
- dev-perl/Text-CSV
- dev-python/pyparsing
- dev-util/pkgconfig"
-
-pkg_setup() {
- if use gstreamer && use pulseaudio ; then
- ewarn "spice-gtk can use only one audio backend: gstreamer will be used since you enabled both."
- fi
-}
-
-src_configure() {
- local audio="no"
- use pulseaudio && audio="pulse"
- use gstreamer && audio="gstreamer"
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable introspection) \
- --with-audio="${audio}" \
- $(use_with !cairo x11) \
- $(use_with python)
-
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- use static-libs || rm -rf "${D}"/usr/lib*/*.la
- use python && rm -rf "${D}"/usr/lib*/python*/site-packages/*.la
- use doc || rm -rf "${D}/usr/share/gtk-doc"
-
- dodoc AUTHORS NEWS README TODO
-
- if use gnome ; then
- insinto /etc/gconf/schemas
- doins "${FILESDIR}/spice.schemas"
- fi
- if use kde ; then
- insinto /usr/share/kde4/services
- doins "${FILESDIR}/spice.protocol"
- fi
-
-}
-
-pkg_preinst() {
- use gnome && gnome2_gconf_savelist
-}
-
-pkg_postinst() {
- use gnome && gnome2_gconf_install
-}
-
-pkg_prerm() {
- use gnome && gnome2_gconf_uninstall
-}
diff --git a/net-misc/spice-gtk/spice-gtk-0.6-r1.ebuild b/net-misc/spice-gtk/spice-gtk-0.7.159-r1.ebuild
index 0753e67e3bb3..188c8dcceb4c 100644
--- a/net-misc/spice-gtk/spice-gtk-0.6-r1.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.7.159-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.6-r1.ebuild,v 1.2 2011/07/24 21:03:11 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.7.159-r1.ebuild,v 1.1 2012/01/19 17:23:47 dev-zero Exp $
-EAPI=3
+EAPI="4"
+GCONF_DEBUG="no"
inherit eutils python gnome2-utils
@@ -10,16 +11,20 @@ PYTHON_DEPEND="python? 2"
DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI."
HOMEPAGE="http://spice-space.org http://gitorious.org/spice-gtk"
-SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
+SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
-IUSE="+cairo doc gnome gstreamer gtk3 introspection kde +pulseaudio python sasl static-libs"
+IUSE="doc gnome gstreamer gtk3 +introspection kde policykit +pulseaudio
+python sasl static-libs usbredir vala"
+# TODO: check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
RDEPEND="pulseaudio? ( !gstreamer? ( media-sound/pulseaudio ) )
- gstreamer? ( media-libs/gstreamer )
- >=app-emulation/spice-protocol-0.8.0-r1
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ >=app-emulation/spice-protocol-0.9.1
>=x11-libs/pixman-0.17.7
>=media-libs/celt-0.5.1.1:0.5.1
dev-libs/openssl
@@ -32,13 +37,26 @@ RDEPEND="pulseaudio? ( !gstreamer? ( media-sound/pulseaudio ) )
introspection? ( dev-libs/gobject-introspection )
python? ( dev-python/pygtk:2 )
sasl? ( dev-libs/cyrus-sasl )
- gnome? ( gnome-base/gconf )"
+ gnome? ( gnome-base/gconf )
+ usbredir? (
+ policykit? (
+ sys-auth/polkit
+ sys-apps/acl )
+ >=dev-libs/libusb-1.0.9_rc1
+ >=sys-apps/usbredir-0.3.1
+ sys-fs/udev[gudev] )"
DEPEND="${RDEPEND}
+ vala? ( dev-lang/vala:0.14 )
dev-lang/python
- dev-lang/perl
- dev-perl/Text-CSV
dev-python/pyparsing
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17"
+
+# Hard-deps while building from git:
+# dev-lang/vala:0.14
+# dev-lang/perl
+# dev-perl/Text-CSV
pkg_setup() {
if use gstreamer && use pulseaudio ; then
@@ -52,29 +70,39 @@ src_configure() {
use pulseaudio && audio="pulse"
use gstreamer && audio="gstreamer"
+ # TODO: do a double build like gtk-vnc does to install both gtk2 & gtk3 libs
use gtk3 && gtk="3.0"
+ if use vala ; then
+ # force vala regen for MinGW, etc
+ rm -fv gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c
+ fi
- econf \
+ econf --disable-maintainer-mode \
+ VALAC=$(type -P valac-0.14) \
+ VAPIGEN=$(type -P vapigen-0.14) \
$(use_enable static-libs static) \
$(use_enable introspection) \
--with-audio="${audio}" \
- $(use_with !cairo x11) \
$(use_with python) \
$(use_with sasl) \
- --with-gtk="${gtk}"
-
+ $(use_enable usbredir) \
+ $(use_enable policykit polkit) \
+ $(use_enable vala) \
+ --with-gtk="${gtk}" \
+ --disable-smartcard \
+ --disable-werror
}
src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ emake -j1 DESTDIR="${D}" install
use static-libs || rm -rf "${D}"/usr/lib*/*.la
use python && rm -rf "${D}"/usr/lib*/python*/site-packages/*.la
use doc || rm -rf "${D}/usr/share/gtk-doc"
- dodoc AUTHORS NEWS README TODO
+ dodoc AUTHORS NEWS README THANKS TODO
- make_desktop_entry spicy Spicy "" net
+ make_desktop_entry spicy Spicy "" "Network;RemoteAccess;"
if use gnome ; then
insinto /etc/gconf/schemas