summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-10-22 20:55:50 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-10-22 20:55:50 +0000
commit7fabe6ed6333a642edc77f8a1becb8a55dbd3da8 (patch)
treec900d26c95b97caa80a28ae7bd00fb0b41f003d3 /net-misc
parentchangelog:P (diff)
downloadhistorical-7fabe6ed6333a642edc77f8a1becb8a55dbd3da8.tar.gz
historical-7fabe6ed6333a642edc77f8a1becb8a55dbd3da8.tar.bz2
historical-7fabe6ed6333a642edc77f8a1becb8a55dbd3da8.zip
changelog:P
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nforce-net/Manifest4
-rw-r--r--net-misc/nforce-net/files/digest-nforce-net-1.0.0261-r21
-rw-r--r--net-misc/nforce-net/files/nforce-net-1.0.0261-kernel-2.6.patch.gzbin0 -> 1407 bytes
-rw-r--r--net-misc/nforce-net/nforce-net-1.0.0261-r2.ebuild91
4 files changed, 94 insertions, 2 deletions
diff --git a/net-misc/nforce-net/Manifest b/net-misc/nforce-net/Manifest
index 4d2f2156ca71..76b5d04a2f75 100644
--- a/net-misc/nforce-net/Manifest
+++ b/net-misc/nforce-net/Manifest
@@ -1,7 +1,7 @@
MD5 7f75d213c4b20e943677e8f700fd9b7d nforce-net-1.0.0261-r1.ebuild 2634
MD5 5d9fce994c578cc57c75bb647113c164 nforce-net-1.0.0256.ebuild 1407
-MD5 46089c7c2289e047ec85238e0ac2ff2b nforce-net-1.0.0261-r2.ebuild 2899
-MD5 1b2704a702234e5257cb5285a3e5cebe ChangeLog 1284
+MD5 7b820e58547d32def943ac8856c01482 nforce-net-1.0.0261-r2.ebuild 2912
+MD5 5d52f2ed17fcacfeab8c9eb9dc9c34ae ChangeLog 1509
MD5 1dacf7c492847765ed9e3c12db33a657 files/nforce-net-1.0.0261-kernel-2.6.patch.gz 1407
MD5 c94d06d6f883700d21e346d79589b307 files/digest-nforce-net-1.0.0261-r1 73
MD5 c94d06d6f883700d21e346d79589b307 files/digest-nforce-net-1.0.0261-r2 73
diff --git a/net-misc/nforce-net/files/digest-nforce-net-1.0.0261-r2 b/net-misc/nforce-net/files/digest-nforce-net-1.0.0261-r2
new file mode 100644
index 000000000000..be8c8c18ae9c
--- /dev/null
+++ b/net-misc/nforce-net/files/digest-nforce-net-1.0.0261-r2
@@ -0,0 +1 @@
+MD5 19e9c6592e8db6ba55c08d42dc49163f NVIDIA_nforce-1.0-0261.tar.gz 87301
diff --git a/net-misc/nforce-net/files/nforce-net-1.0.0261-kernel-2.6.patch.gz b/net-misc/nforce-net/files/nforce-net-1.0.0261-kernel-2.6.patch.gz
new file mode 100644
index 000000000000..4ddb1fcea557
--- /dev/null
+++ b/net-misc/nforce-net/files/nforce-net-1.0.0261-kernel-2.6.patch.gz
Binary files differ
diff --git a/net-misc/nforce-net/nforce-net-1.0.0261-r2.ebuild b/net-misc/nforce-net/nforce-net-1.0.0261-r2.ebuild
new file mode 100644
index 000000000000..5f52a15fc925
--- /dev/null
+++ b/net-misc/nforce-net/nforce-net-1.0.0261-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nforce-net/nforce-net-1.0.0261-r2.ebuild,v 1.1 2003/10/22 20:55:42 lanius Exp $
+
+inherit gcc kernel-mod
+
+NV_V="${PV/1.0./1.0-}"
+NV_PACKAGE="NVIDIA_nforce-${NV_V}"
+S="${WORKDIR}/nforce/nvnet"
+DESCRIPTION="Linux kernel module for the NVIDIA's nForce network chip"
+HOMEPAGE="http://www.nvidia.com/"
+SRC_URI="http://download.nvidia.com/XFree86/nforce/${NV_V}/${NV_PACKAGE}.tar.gz"
+
+# The SLOT needs to be set to $KV to prevent unmerges of modules for other kernels
+LICENSE="NVIDIA"
+SLOT="${KV}"
+KEYWORDS="-* x86"
+RESTRICT="nostrip"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ if kernel-mod_is_2_5_kernel || kernel-mod_is_2_6_kernel
+ then
+ EPATCH_SINGLE_MSG="Applying 2.5/6 patch ..." \
+ epatch ${FILESDIR}/nforce-net-1.0.0261-kernel-2.6.patch.gz
+ fi
+
+ make KERNSRC="/usr/src/linux" || die
+}
+
+src_install() {
+ # The driver goes into the standard modules location
+ insinto /lib/modules/${KV}/kernel/drivers/net
+
+ if kernel-mod_is_2_5_kernel || kernel-mod_is_2_6_kernel
+ then
+ doins nvnet.ko
+ else
+ doins nvnet.o
+ fi
+
+ # Docs
+ dodoc ${S}/ReleaseNotes.html
+
+ dodir /etc/modules.d
+ cat > ${D}/etc/modules.d/nvnet << EOF
+# The nForce network driver supports two optimization modes:
+# optimization=0 ; Throughput optimization
+# optimization=1 ; CPU optimization
+# CPU optimization mode ruduces the CPU utilization by using
+# interrupt moderation. Throughput optimization mode maximizes
+# the throughput. This mode has higher CPU consumption.
+# By default, the driver runs in throughput optimization mode.
+
+# The "speed" module parameter can be used set the interface
+# speed of the ethernet controller. By default the controller
+# will autosense the interface speed, but also supports the
+# following values:
+# speed=0 ; auto
+# speed=1 ; 10Mbps
+# speed=2 ; 100Mpbs
+
+# The "duplex" module parameter can be used to specify the
+# interface duplex. By default the controller will autoselect
+# duplex, but also supports the following values:
+# duplex=0 ; auto
+# duplex=1 ; half duplex
+# duplex=2 ; full duplex
+
+options nvnet optimization="1" speed="0" duplex="0"
+EOF
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ # Update module dependency
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ echo
+ einfo "You need to add \"nvnet\" to your /etc/modules.autoload to load"
+ einfo "this module when the system is started. Alternatively, you can"
+ einfo "use the 'hotplug' package ('emerge hotplug' then 'rc-update add"
+ einfo "hotplug default') to auto-detect and load \"nvnet\" on startup."
+ echo
+ einfo "Edit /etc/modules.d/nvnet and run \"update-modules\" to configure"
+ einfo "the \"nvnet\" driver for throughput optimization the next time it"
+ einfo "is loaded."
+}