summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-22 20:23:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-22 20:23:49 +0000
commit0d6550d9fd98d623c4d0899aea21b8247e44a2ca (patch)
tree4a329c18c82524a85332af72b317739018f35cca /net-nds/openldap/openldap-2.2.14.ebuild
parentBump to 1.9.1. Removed 1.9.0. (diff)
downloadhistorical-0d6550d9fd98d623c4d0899aea21b8247e44a2ca.tar.gz
historical-0d6550d9fd98d623c4d0899aea21b8247e44a2ca.tar.bz2
historical-0d6550d9fd98d623c4d0899aea21b8247e44a2ca.zip
Bug #55706, add BDB checkpoints to config.
Diffstat (limited to 'net-nds/openldap/openldap-2.2.14.ebuild')
-rw-r--r--net-nds/openldap/openldap-2.2.14.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/net-nds/openldap/openldap-2.2.14.ebuild b/net-nds/openldap/openldap-2.2.14.ebuild
index e7c86351cd27..04992f7a2100 100644
--- a/net-nds/openldap/openldap-2.2.14.ebuild
+++ b/net-nds/openldap/openldap-2.2.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.2.14.ebuild,v 1.1 2004/07/09 16:55:06 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.2.14.ebuild,v 1.2 2004/08/22 20:23:49 robbat2 Exp $
inherit eutils
@@ -171,14 +171,12 @@ src_install() {
keepdir /var/run/openldap
fowners ldap:ldap /var/run/openldap
fperms 0755 /var/run/openldap
- sed -i -e "s:/var/lib/slapd.pid:/var/run/openldap/slapd.pid:" ${D}/etc/openldap/slapd.conf
- sed -i -e "s:/var/lib/slapd.pid:/var/run/openldap/slapd.pid:" ${D}/etc/openldap/slapd.conf.default
- sed -i -e "s:/var/lib/slapd.args:/var/run/openldap/slapd.args:" ${D}/etc/openldap/slapd.conf
- sed -i -e "s:/var/lib/slapd.args:/var/run/openldap/slapd.args:" ${D}/etc/openldap/slapd.conf.default
- fowners root:ldap /etc/openldap/slapd.conf
- fperms 0640 /etc/openldap/slapd.conf
- fowners root:ldap /etc/openldap/slapd.conf.default
- fperms 0640 /etc/openldap/slapd.conf.default
+ for f in /etc/openldap/slapd.conf /etc/openldap/slapd.conf.default; do
+ sed -e "s:/var/lib/slapd.:/var/run/openldap/slapd.:" -i ${D}/${f}
+ sed -e "/database\tbdb$/acheckpoint 32 30 # <kbyte> <min>" -i ${D}/${f}
+ fowners root:ldap ${f}
+ fperms 0640 ${f}
+ done
# install our own init scripts
exeinto /etc/init.d
@@ -214,10 +212,8 @@ pkg_postinst() {
# Let's make sure these permissions are correct.
chown ldap:ldap /var/run/openldap
chmod 0755 /var/run/openldap
- chown root:ldap /etc/openldap/slapd.conf
- chmod 0640 /etc/openldap/slapd.conf
- chown root:ldap /etc/openldap/slapd.conf.default
- chmod 0640 /etc/openldap/slapd.conf.default
+ chown root:ldap /etc/openldap/slapd.conf{,.default}
+ chmod 0640 /etc/openldap/slapd.conf{,.default}
chown ldap:ldap /var/lib/openldap-{data,ldbm,slurp}
# notes from bug #41297, bug #41039