summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-27 23:29:39 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-27 23:29:39 +0000
commitee39e4531ecc10e1d75bce63b6292e5217af6eb6 (patch)
tree64e00e05aaa39d1ccc53f5df5287aa1ae261b32c /net-nds/ypbind
parentversion bump (diff)
downloadhistorical-ee39e4531ecc10e1d75bce63b6292e5217af6eb6.tar.gz
historical-ee39e4531ecc10e1d75bce63b6292e5217af6eb6.tar.bz2
historical-ee39e4531ecc10e1d75bce63b6292e5217af6eb6.zip
version bump and USE dependent nls support
Diffstat (limited to 'net-nds/ypbind')
-rw-r--r--net-nds/ypbind/ChangeLog10
-rw-r--r--net-nds/ypbind/files/digest-ypbind-1.101
-rw-r--r--net-nds/ypbind/files/digest-ypbind-1.7-r11
-rw-r--r--net-nds/ypbind/ypbind-1.10.ebuild34
-rw-r--r--net-nds/ypbind/ypbind-1.7-r1.ebuild31
5 files changed, 44 insertions, 33 deletions
diff --git a/net-nds/ypbind/ChangeLog b/net-nds/ypbind/ChangeLog
index 780fe12d1ec0..c98be7fef084 100644
--- a/net-nds/ypbind/ChangeLog
+++ b/net-nds/ypbind/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-nds/ypbind
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.1 2002/02/01 21:53:36 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.2 2002/04/27 23:29:39 seemant Exp $
+
+*ypbind-1.10 (27 Apr 2002)
+
+ 27 Apr 2002; Seemant Kulleen <seemant@gentoo.org> ypbind-1.10.ebuild
+ files/digest-ypbind-1.10 :
+
+ Version bump, including USE dependent NLS support. Thanks to bug #1146 by
+ stefan@mdy.univie.ac.at (Stefan Boresch)
*ypbind-1.7-r6 (1 Feb 2002)
diff --git a/net-nds/ypbind/files/digest-ypbind-1.10 b/net-nds/ypbind/files/digest-ypbind-1.10
new file mode 100644
index 000000000000..9dedd6bb7284
--- /dev/null
+++ b/net-nds/ypbind/files/digest-ypbind-1.10
@@ -0,0 +1 @@
+MD5 7d1a9088afaf3c5051c702ea1c37d42b ypbind-mt-1.10.tar.gz 205122
diff --git a/net-nds/ypbind/files/digest-ypbind-1.7-r1 b/net-nds/ypbind/files/digest-ypbind-1.7-r1
deleted file mode 100644
index e1f081d40334..000000000000
--- a/net-nds/ypbind/files/digest-ypbind-1.7-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d6f98266a18f25337cd6afdb8282af4f ypbind-mt-1.7.tar.gz 151825
diff --git a/net-nds/ypbind/ypbind-1.10.ebuild b/net-nds/ypbind/ypbind-1.10.ebuild
new file mode 100644
index 000000000000..d63a0bd2623f
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.10.ebuild,v 1.1 2002/04/27 23:29:39 seemant Exp $
+
+MY_P=${PN}-mt-${PV}
+S=${WORKDIR}/ypbind-mt-${PV}
+DESCRIPTION="Multithreaded NIS bind service"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.gz"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+
+DEPEND="net-nds/yp-tools
+ net-nds/portmap"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+
+ insinto /etc ; doins etc/yp.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ypbind.rc6 ypbind
+}
diff --git a/net-nds/ypbind/ypbind-1.7-r1.ebuild b/net-nds/ypbind/ypbind-1.7-r1.ebuild
deleted file mode 100644
index 4495f7a2703b..000000000000
--- a/net-nds/ypbind/ypbind-1.7-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.7-r1.ebuild,v 1.2 2001/10/06 07:00:02 woodchip Exp $
-
-A=ypbind-mt-${PV}.tar.gz
-S=${WORKDIR}/ypbind-mt-${PV}
-DESCRIPTION="Multithreaded NIS bind service"
-SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/"${A}
-HOMEPAGE="http://www.suse.de/~kukuk/nis/ypbind-mt/index.html"
-
-DEPEND="virtual/glibc"
-RDEPEND="virtual/glibc
- net-nds/yp-tools
- net-nds/portmap"
-
-src_compile() {
- ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man
- assert "bad configure"
- make || die
-}
-
-src_install() {
- make prefix=${D}/usr sysconfdir=${D}/etc mandir=${D}/usr/share/man install || die
- dodoc AUTHORS ChangeLog COPYING README THANKS TODO
-
- insinto /etc ; doins etc/yp.conf
-
- exeinto /etc/rc.d/init.d
- newexe ${FILESDIR}/ypbind.rc5 ypbind
-}