summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 22:48:36 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 22:48:36 +0000
commit469f2838551e03f068b0ea4f91eb6c40628a8bfa (patch)
tree67f579494ad4479355b2d441409eee22c15c19b0 /net-nds
parent*** empty log message *** (diff)
downloadhistorical-469f2838551e03f068b0ea4f91eb6c40628a8bfa.tar.gz
historical-469f2838551e03f068b0ea4f91eb6c40628a8bfa.tar.bz2
historical-469f2838551e03f068b0ea4f91eb6c40628a8bfa.zip
*** empty log message ***
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/files/digest-openldap-2.0.71
-rw-r--r--net-nds/openldap/openldap-2.0.7.ebuild50
-rw-r--r--net-nds/ypbind/files/digest-ypbind-1.71
-rw-r--r--net-nds/ypbind/ypbind-1.7.ebuild37
4 files changed, 89 insertions, 0 deletions
diff --git a/net-nds/openldap/files/digest-openldap-2.0.7 b/net-nds/openldap/files/digest-openldap-2.0.7
new file mode 100644
index 000000000000..48982066fa3d
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.7
@@ -0,0 +1 @@
+MD5 e772449b0fcc64dc4e7bf20c2853dd10 openldap-2.0.7.tgz
diff --git a/net-nds/openldap/openldap-2.0.7.ebuild b/net-nds/openldap/openldap-2.0.7.ebuild
new file mode 100644
index 000000000000..883b6d0c0078
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.7.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/"${A}
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --enable-wrappers --enable-passwd \
+ --enable-shell --enable-shared --enable-static \
+ --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ try make depend
+ try make
+ cd tests
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/state install
+ prepman
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc
+ dodoc doc/rfc/*.txt
+ docinto devel
+ dodoc doc/devel/*
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/slapd ${D}/etc/rc.d/init.d
+ cp ${O}/files/slurpd ${D}/etc/rc.d/init.d
+
+ cd ${D}/etc/openldap
+
+ for i in *
+ do
+ dosed $i
+ done
+}
+
+
+
+
+
+
diff --git a/net-nds/ypbind/files/digest-ypbind-1.7 b/net-nds/ypbind/files/digest-ypbind-1.7
new file mode 100644
index 000000000000..f94aa2fa644f
--- /dev/null
+++ b/net-nds/ypbind/files/digest-ypbind-1.7
@@ -0,0 +1 @@
+MD5 d6f98266a18f25337cd6afdb8282af4f ypbind-mt-1.7.tar.gz
diff --git a/net-nds/ypbind/ypbind-1.7.ebuild b/net-nds/ypbind/ypbind-1.7.ebuild
new file mode 100644
index 000000000000..19bd56bce105
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.7.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+A=ypbind-mt-${PV}.tar.gz
+S=${WORKDIR}/ypbind-mt-${PV}
+DESCRIPTION="Multithreaded NIS bind service"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/"${A}
+HOMEPAGE="http://www.suse.de/~kukuk/nis/ypbind-mt/index.html"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/yp --with-catgets
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ insinto /etc/rc.d/init.d
+ doins ${O}/files/ypbind
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+ insinto /etc/yp
+ doins etc/yp.conf
+ prepman
+}
+
+
+
+