summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-08-01 14:37:25 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-08-01 14:37:25 +0000
commit1006b4fd517b43670b0e046ee202a2b2073927a8 (patch)
tree267fa1cc25c745044c0844303c5488b80061ef1c /net-news/pan
parentrepoman'd (diff)
downloadhistorical-1006b4fd517b43670b0e046ee202a2b2073927a8.tar.gz
historical-1006b4fd517b43670b0e046ee202a2b2073927a8.tar.bz2
historical-1006b4fd517b43670b0e046ee202a2b2073927a8.zip
New version
Diffstat (limited to 'net-news/pan')
-rw-r--r--net-news/pan/ChangeLog7
-rw-r--r--net-news/pan/files/digest-pan-0.12.921
-rw-r--r--net-news/pan/pan-0.12.92.ebuild64
3 files changed, 71 insertions, 1 deletions
diff --git a/net-news/pan/ChangeLog b/net-news/pan/ChangeLog
index ddb4d3acc67f..88675b38803e 100644
--- a/net-news/pan/ChangeLog
+++ b/net-news/pan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-news/pan
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.14 2002/07/28 17:56:36 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.15 2002/08/01 14:37:25 stroke Exp $
+
+*pan-0.12.92 (1 Aug 2002)
+
+ 1 Aug 2002; Gabriele Giorgetti <stroke@gentoo.org> pan-0.12.92.ebuild:
+ New version.
*pan-0.12.91 (28 July 2002)
diff --git a/net-news/pan/files/digest-pan-0.12.92 b/net-news/pan/files/digest-pan-0.12.92
new file mode 100644
index 000000000000..af29b9b002d0
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.12.92
@@ -0,0 +1 @@
+MD5 175c036783dc9cb78ee5dfa981b72806 pan-0.12.92.tar.bz2 1620211
diff --git a/net-news/pan/pan-0.12.92.ebuild b/net-news/pan/pan-0.12.92.ebuild
new file mode 100644
index 000000000000..12bcac781656
--- /dev/null
+++ b/net-news/pan/pan-0.12.92.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.12.92.ebuild,v 1.1 2002/08/01 14:37:25 stroke Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=dev-libs/libxml2-2.4.22
+ spell? ( >=app-text/gtkspell-2.0.0 )"
+
+DEPEND="$RDEPEND"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="--disable-nls"
+
+ if [ -n "`use gtkspell`" ] ; then
+ myconf="${myconf} --enable-gtkspell=yes"
+ else
+ myconf="${myconf} --enable-gtkspell=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib \
+ --enable-debug=yes \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ emake prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ localstatedir=${D}/var/lib \
+ install || die "installation failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+}
+
+