summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-10 18:42:29 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-10 18:42:29 +0000
commit2a638a7154d3367d0e74bc74b95aec62d86cf119 (patch)
tree1bf0ae99d7eea7e0f4bb59287601ee1fb8961157 /net-p2p/gnunet
parentNew package. Submitted by Ilian Zarov. Fixes #4284 (diff)
downloadhistorical-2a638a7154d3367d0e74bc74b95aec62d86cf119.tar.gz
historical-2a638a7154d3367d0e74bc74b95aec62d86cf119.tar.bz2
historical-2a638a7154d3367d0e74bc74b95aec62d86cf119.zip
New package. submitted by Ilian Zarov. Fixes #4298
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/ChangeLog13
-rw-r--r--net-p2p/gnunet/files/digest-gnunet-0.4.21
-rw-r--r--net-p2p/gnunet/files/gnunet26
-rw-r--r--net-p2p/gnunet/gnunet-0.4.2.ebuild41
4 files changed, 81 insertions, 0 deletions
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
new file mode 100644
index 000000000000..5b66c9727436
--- /dev/null
+++ b/net-p2p/gnunet/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-p2p/gnunet
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.1 2002/07/10 18:42:29 rphillips Exp $
+
+*gnunet-0.4.2 (10 Jul 2002)
+
+ 10 Jul 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-p2p/gnunet/files/digest-gnunet-0.4.2 b/net-p2p/gnunet/files/digest-gnunet-0.4.2
new file mode 100644
index 000000000000..174699995005
--- /dev/null
+++ b/net-p2p/gnunet/files/digest-gnunet-0.4.2
@@ -0,0 +1 @@
+MD5 b820139fe4d9dcb7a9fad79e37b3c0a8 GNUnet-0.4.2.tar.bz2 199906
diff --git a/net-p2p/gnunet/files/gnunet b/net-p2p/gnunet/files/gnunet
new file mode 100644
index 000000000000..df52d40b1834
--- /dev/null
+++ b/net-p2p/gnunet/files/gnunet
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# description: Gnunet is an anonymous distributed secure network
+# this server is required to connect to the network,
+# it will open a TCP port to communicate with the
+# GUI and an UDP port to communicate with the world.
+# NOTE: I have not tested this script.
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting gnunetd"
+ # -u username, -c path to gnunet.conf file
+ start-stop-daemon --start --quiet --exec /usr/local/bin/gnunetd -u gnunet \
+ -c /var/lib/GNUnet/gnunet.conf
+ eend $? "Failed to start gnunetd"
+}
+
+stop() {
+ ebegin "Stopping gnunetd"
+ start-stop-daemon --stop --quiet --exec /usr/local/bin/gnunetd
+ eend $? "Failed to stop gnunetd"
+}
diff --git a/net-p2p/gnunet/gnunet-0.4.2.ebuild b/net-p2p/gnunet/gnunet-0.4.2.ebuild
new file mode 100644
index 000000000000..3073a754b7d4
--- /dev/null
+++ b/net-p2p/gnunet/gnunet-0.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.4.2.ebuild,v 1.1 2002/07/10 18:42:29 rphillips Exp $
+
+DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
+HOMEPAGE="http://www.ovmj.org/GNUnet/index.php3"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-libs/openssl-0.9.6d
+ >=sys-libs/gdbm-1.8.0
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=dev-libs/libextractor-0.1.0"
+RDEPEND="${DEPEND}"
+SRC_URI="http://www.ovmj.org/GNUnet/download/GNUnet-${PV}.tar.bz2"
+S=${WORKDIR}/GNUnet-${PV}
+
+src_compile () {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING INSTALL NEWS README
+ mkdir ${D}/usr/share/gnunet
+ cp ${S}/contrib/gnunet.conf* ${D}/usr/share/gnunet
+ cp ${FILESDIR}/gnunet ${D}/usr/share/gnunet
+
+}
+
+pkg_postinstall () {
+ einfo "Default configuration files are provided in /usr/share/gnunet"
+ einfo "An example rc script for gentoo is also available and "
+ einfo "should be run by permanent nodes."
+ einfo "Read the docs for more details"
+}