summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-02 13:10:38 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-02 13:10:38 +0000
commit985e792d80e7309bdfed8dab80bde124d408567e (patch)
treec47e4a23bbf5f88f488cd197dce5af3d8767cedb /net-p2p/lopster/lopster-1.0.1.20020702.ebuild
parenttypo (diff)
downloadhistorical-985e792d80e7309bdfed8dab80bde124d408567e.tar.gz
historical-985e792d80e7309bdfed8dab80bde124d408567e.tar.bz2
historical-985e792d80e7309bdfed8dab80bde124d408567e.zip
bug fix0rs for nls/intl stuff
Diffstat (limited to 'net-p2p/lopster/lopster-1.0.1.20020702.ebuild')
-rw-r--r--net-p2p/lopster/lopster-1.0.1.20020702.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/lopster/lopster-1.0.1.20020702.ebuild b/net-p2p/lopster/lopster-1.0.1.20020702.ebuild
new file mode 100644
index 000000000000..7975548757e0
--- /dev/null
+++ b/net-p2p/lopster/lopster-1.0.1.20020702.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lopster/lopster-1.0.1.20020702.ebuild,v 1.1 2002/07/02 13:10:38 seemant Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A Napster Client using GTK"
+SRC_URI="http://www.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/${P}.tar.bz2"
+HOMEPAGE="http://lopster.sourceforge.net"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="=x11-libs/gtk+-1.2*"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ ./autogen.sh
+ autoconf
+ cp configure.in configure.in.orig
+ sed -e "s:^intl/Makefile::" \
+ -e "s:AM_GNU_GETTEXT::" \
+ configure.in.orig > configure.in
+
+ cp Makefile.am Makefile.am.orig
+ sed "s:SUBDIR.*:SUBDIRS = m4 src:" \
+ Makefile.am.orig > Makefile.am
+
+ automake
+
+ econf || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+ dodoc AUTHORS BUGS README ChangeLog NEWS TODO
+}
+