summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-02-11 20:40:20 +0000
committerMichael Weber <xmw@gentoo.org>2014-02-11 20:40:20 +0000
commit8edb6b597dfec2edde44f236c622b1ba56c8c029 (patch)
treefcc370ac42ff9e451b88255401d3b88429204c33 /net-p2p/ncdc/ncdc-1.19.ebuild
parentreduce-memory-overheads options is not recognized by ld.gold (#469942 by Samu... (diff)
downloadhistorical-8edb6b597dfec2edde44f236c622b1ba56c8c029.tar.gz
historical-8edb6b597dfec2edde44f236c622b1ba56c8c029.tar.bz2
historical-8edb6b597dfec2edde44f236c622b1ba56c8c029.zip
Version bump, new USE geoip
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x62EEF090
Diffstat (limited to 'net-p2p/ncdc/ncdc-1.19.ebuild')
-rw-r--r--net-p2p/ncdc/ncdc-1.19.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-p2p/ncdc/ncdc-1.19.ebuild b/net-p2p/ncdc/ncdc-1.19.ebuild
new file mode 100644
index 000000000000..c19d630e5883
--- /dev/null
+++ b/net-p2p/ncdc/ncdc-1.19.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-1.19.ebuild,v 1.1 2014/02/11 20:39:49 xmw Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="ncurses directconnect client"
+HOMEPAGE="http://dev.yorhel.nl/ncdc"
+SRC_URI="http://dev.yorhel.nl/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="geoip"
+
+RDEPEND="app-arch/bzip2
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ net-libs/gnutls
+ sys-libs/ncurses:5[unicode]
+ sys-libs/zlib
+ geoip? ( dev-libs/geoip )"
+DEPEND="${RDEPEND}
+ dev-util/makeheaders
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_with geoip)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}