summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-10-05 17:23:24 +0000
committerJon Hood <squinky86@gentoo.org>2004-10-05 17:23:24 +0000
commit8614c7eaec91ac3272be7660197465b6b24a48bf (patch)
treed1a882988a1e6e223b70e7ce6a32c86f461d11ec /net-p2p/ww
parentInitial import, #65135 (diff)
downloadhistorical-8614c7eaec91ac3272be7660197465b6b24a48bf.tar.gz
historical-8614c7eaec91ac3272be7660197465b6b24a48bf.tar.bz2
historical-8614c7eaec91ac3272be7660197465b6b24a48bf.zip
use CFLAGS correctly
Diffstat (limited to 'net-p2p/ww')
-rw-r--r--net-p2p/ww/Manifest8
-rw-r--r--net-p2p/ww/ww-2.26.ebuild10
2 files changed, 11 insertions, 7 deletions
diff --git a/net-p2p/ww/Manifest b/net-p2p/ww/Manifest
index 7226d481c2c3..00e77fa8a1e3 100644
--- a/net-p2p/ww/Manifest
+++ b/net-p2p/ww/Manifest
@@ -1,14 +1,14 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 3c678e49a2ed30c88346b581a3fe6c86 ww-2.26.ebuild 789
+MD5 3b6084cf4923bf70b6723433e1083a9a ww-2.26.ebuild 776
MD5 e8facf61d1a7cf3174ef2e3e5775da74 ChangeLog 396
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
MD5 46595625648ee3834e54ff1fd6bfd52a files/digest-ww-2.26 59
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBYtfRcAgAdbxYsnERAogGAJwK6/AR6991XIuzM0sJKUt6G7uxqgCdFx/D
-Q6hRL6yjvLCHUnXwQDblnOg=
-=8cdh
+iD8DBQFBYtiScAgAdbxYsnERAsCkAJwJk6az14ZLr0DvbzE2hEfOWkKenwCglwpM
+EYUFPpePtCHFaeo4YYg6uJY=
+=cwMv
-----END PGP SIGNATURE-----
diff --git a/net-p2p/ww/ww-2.26.ebuild b/net-p2p/ww/ww-2.26.ebuild
index 716352c21b65..33981c1112c1 100644
--- a/net-p2p/ww/ww-2.26.ebuild
+++ b/net-p2p/ww/ww-2.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ww/ww-2.26.ebuild,v 1.1 2004/10/05 17:20:06 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ww/ww-2.26.ebuild,v 1.2 2004/10/05 17:23:24 squinky86 Exp $
DESCRIPTION="White Water allows people to publish files for download by thousands of people without saturating their bandwidth."
HOMEPAGE="http://ww.walrond.org"
@@ -11,9 +11,13 @@ KEYWORDS="~x86"
IUSE=""
DEPEND=">=dev-libs/openssl-0.9.7"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:-O3:${CFLAGS}:g' Makefile */Makefile
+}
+
src_compile() {
- sed -e "s/-O3/${CFLAGS}/g" Makefile > Makefile.$$
- mv -f Makefile.$$ Makefile || die "moving Makefile"
make clean || die "make clean"
make deps || die "make deps"
make release || die "make release"