summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-10-31 16:11:14 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-10-31 16:11:14 +0000
commite9a383783af448ea3e2c145788745eecd3f7c824 (patch)
tree6c049587a406dcdc3fb970b691b692ca32efb19c /net-p2p/xmule/xmule-1.9.3.ebuild
parentFix pam_console_apply -r segfaulting if a group used in (diff)
downloadhistorical-e9a383783af448ea3e2c145788745eecd3f7c824.tar.gz
historical-e9a383783af448ea3e2c145788745eecd3f7c824.tar.bz2
historical-e9a383783af448ea3e2c145788745eecd3f7c824.zip
Version bumped.
Diffstat (limited to 'net-p2p/xmule/xmule-1.9.3.ebuild')
-rw-r--r--net-p2p/xmule/xmule-1.9.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/xmule/xmule-1.9.3.ebuild b/net-p2p/xmule/xmule-1.9.3.ebuild
new file mode 100644
index 000000000000..7b4b4f992044
--- /dev/null
+++ b/net-p2p/xmule/xmule-1.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.9.3.ebuild,v 1.1 2004/10/31 16:11:14 mholzer Exp $
+
+inherit wxwidgets
+
+DESCRIPTION="wxWidgets based client for the eDonkey/eMule/lMule network"
+HOMEPAGE="http://xmule.ws/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2 ZLIB GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+IUSE="nls gtk2 debug"
+
+DEPEND=">=x11-libs/wxGTK-2.4.2-r2
+ nls? ( sys-devel/gettext )
+ >=sys-libs/zlib-1.2.1
+ !net-p2p/amule"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's/@datadir@/${DESTDIR}@datadir@/' Makefile.in || die
+}
+
+src_compile () {
+ local myconf=
+
+ if ! use gtk2 ; then
+ need-wxwidgets gtk
+ else
+ need-wxwidgets gtk2
+ fi
+
+ myconf="${myconf} --with-zlib=/tmp/zlib/"
+
+ myconf="${myconf} `use_enable debug` `use_enable nls`"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ einstall mkinstalldirs=${S}/mkinstalldirs DESTDIR=${D} || die
+ rm -rf ${D}/var || die
+}