summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-05-08 07:26:56 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-05-08 07:26:56 +0000
commite992ff6a2669b0b164a6e5af57af8bd8c5c86918 (patch)
tree74e17f1733816f22fb68bd2aa0f02ea7004edf2f /net-p2p
parentremoved unnecessary patch, made X support optional as supposed in bug 20608 (diff)
downloadhistorical-e992ff6a2669b0b164a6e5af57af8bd8c5c86918.tar.gz
historical-e992ff6a2669b0b164a6e5af57af8bd8c5c86918.tar.bz2
historical-e992ff6a2669b0b164a6e5af57af8bd8c5c86918.zip
removed unnecessary patch, made X support optional as supposed in bug 20608
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/Manifest4
-rw-r--r--net-p2p/bittorrent/bittorrent-3.2.1b-r2.ebuild50
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-3.2.1b-r21
3 files changed, 53 insertions, 2 deletions
diff --git a/net-p2p/bittorrent/Manifest b/net-p2p/bittorrent/Manifest
index b59b2dd5e66f..d4efeeb1a53e 100644
--- a/net-p2p/bittorrent/Manifest
+++ b/net-p2p/bittorrent/Manifest
@@ -1,8 +1,8 @@
-MD5 347b956f6403d85655c053faee3b6c04 bittorrent-3.2.1b-r2.ebuild 1427
+MD5 d6f624d1d024f929ca277f5ae991bb68 bittorrent-3.2.1b-r2.ebuild 1427
MD5 be16d9b7fde53306624acbee27d45e5b bittorrent-3.2.1b.ebuild 1212
MD5 9c8b6d20b4b666a614ef2a48e7584302 bittorrent-3.2.1b-r1.ebuild 1292
MD5 08d924316cb9e9d5c862eaf954a51572 bittorrent-3.2.1.ebuild 1211
-MD5 22df609cb75b6e970cd2db8fcfa9aedc ChangeLog 1168
+MD5 aad4ab5d762fd4614a32021986fb513b ChangeLog 1410
MD5 18e4d423bad1434f67f294f131f2e181 files/digest-bittorrent-3.2.1b 69
MD5 18e4d423bad1434f67f294f131f2e181 files/digest-bittorrent-3.2.1b-r1 69
MD5 18e4d423bad1434f67f294f131f2e181 files/digest-bittorrent-3.2.1b-r2 69
diff --git a/net-p2p/bittorrent/bittorrent-3.2.1b-r2.ebuild b/net-p2p/bittorrent/bittorrent-3.2.1b-r2.ebuild
new file mode 100644
index 000000000000..cee1d93e5b56
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-3.2.1b-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.2.1b-r2.ebuild,v 1.1 2003/05/08 07:26:31 phosphan Exp $
+
+inherit distutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+SRC_URI="http://bitconjurer.org/BitTorrent/${MY_P}.tar.gz"
+HOMEPAGE="http://bitconjurer.org/BitTorrent"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86"
+
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+
+
+mydoc="FAQ.txt README.txt LICENSE.txt"
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+}
+
+pkg_postinst() {
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' /etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," /etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> /etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' /etc/mailcap
+ fi
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-3.2.1b-r2 b/net-p2p/bittorrent/files/digest-bittorrent-3.2.1b-r2
new file mode 100644
index 000000000000..cfa354976ae9
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-3.2.1b-r2
@@ -0,0 +1 @@
+MD5 9e0cc346a4bfa3904380ed119d8bac90 BitTorrent-3.2.1b.tar.gz 144420