summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-05-07 13:00:34 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-05-07 13:00:34 +0000
commitec00afa268e998363c5aa30f7507915aa4d57a53 (patch)
treeb3d94763fcad9f197e240178d4bf66dd3b96f875 /net-p2p
parentNew versions, cleanup and mark 1.1.8 x86 (diff)
downloadhistorical-ec00afa268e998363c5aa30f7507915aa4d57a53.tar.gz
historical-ec00afa268e998363c5aa30f7507915aa4d57a53.tar.bz2
historical-ec00afa268e998363c5aa30f7507915aa4d57a53.zip
fixes gtk2 compile problems and add changelog entry
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/lmule/ChangeLog8
-rw-r--r--net-p2p/lmule/Manifest5
-rw-r--r--net-p2p/lmule/files/lmule-1.2.0.1-disable_gtk2_prompt.patch10
-rw-r--r--net-p2p/lmule/lmule-1.2.0.1.ebuild13
4 files changed, 31 insertions, 5 deletions
diff --git a/net-p2p/lmule/ChangeLog b/net-p2p/lmule/ChangeLog
index c1572dc77758..75685ed1e931 100644
--- a/net-p2p/lmule/ChangeLog
+++ b/net-p2p/lmule/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/lmule
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/lmule/ChangeLog,v 1.1 2003/04/18 17:55:26 malverian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lmule/ChangeLog,v 1.2 2003/05/07 13:00:25 liquidx Exp $
+
+*lmule-1.2.0.1 (07 May 2003)
+
+ 07 May 2003; Alastair Tse <liquidx@gentoo.org> lmule-1.2.0.1.ebuild:
+ Add a changelog entry that hanno forgot to put in. Fix various configure
+ and compile problems that no one bothered to fix.
*lmule-1.1.13c (18 Apr 2003)
diff --git a/net-p2p/lmule/Manifest b/net-p2p/lmule/Manifest
index ba8bb002f9e6..d9812eb829c2 100644
--- a/net-p2p/lmule/Manifest
+++ b/net-p2p/lmule/Manifest
@@ -1,5 +1,6 @@
-MD5 06ce5d1fa82ef95162f79869951c3648 ChangeLog 333
+MD5 2a6fbca15ca9db85ef22259d31edb06c ChangeLog 561
MD5 66d1123e3e8a1e3f40676f07632f9c94 lmule-1.1.13c.ebuild 568
-MD5 b21a2c6969092fd7a2aaae4782a13100 lmule-1.2.0.1.ebuild 567
+MD5 f6e00f40d454f7b56bd90f9cd968028f lmule-1.2.0.1.ebuild 803
MD5 29359022dbcfedd8168f3e7adfc99b58 files/digest-lmule-1.1.13c 66
MD5 849664b626702680db5062f7736b37a5 files/digest-lmule-1.2.0.1 66
+MD5 f0435eff2167740a9a01d3485f0b97e9 files/lmule-1.2.0.1-disable_gtk2_prompt.patch 281
diff --git a/net-p2p/lmule/files/lmule-1.2.0.1-disable_gtk2_prompt.patch b/net-p2p/lmule/files/lmule-1.2.0.1-disable_gtk2_prompt.patch
new file mode 100644
index 000000000000..1c150471dcff
--- /dev/null
+++ b/net-p2p/lmule/files/lmule-1.2.0.1-disable_gtk2_prompt.patch
@@ -0,0 +1,10 @@
+--- configure 2003-05-07 13:14:36.000000000 +0100
++++ configure 2003-05-07 13:14:46.000000000 +0100
+@@ -7596,7 +7596,6 @@
+ Press enter to continue anyway or ctrl+c to stop.
+ Please, switch to GTK1, it will work better.
+ " >&2;}
+- read
+ CFLAGS="$CFLAGS -D__GTK2__"
+ else
+
diff --git a/net-p2p/lmule/lmule-1.2.0.1.ebuild b/net-p2p/lmule/lmule-1.2.0.1.ebuild
index 8ea0d75c1592..5009e75d13ed 100644
--- a/net-p2p/lmule/lmule-1.2.0.1.ebuild
+++ b/net-p2p/lmule/lmule-1.2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/lmule/lmule-1.2.0.1.ebuild,v 1.1 2003/04/27 17:41:29 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lmule/lmule-1.2.0.1.ebuild,v 1.2 2003/05/07 13:00:25 liquidx Exp $
DESCRIPTION="GPL eDonkey clone that doesn't suck"
HOMEPAGE="http://lmule.sourceforge.net"
@@ -13,8 +13,17 @@ DEPEND=">=x11-libs/wxGTK-2.4
S=${WORKDIR}/${P}
IUSE=""
+# no parallel builds
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ einfo "Patching configure to remove GTK2 prompt.."
+ cd ${S}; patch -p0 < ${FILESDIR}/${P}-disable_gtk2_prompt.patch
+}
+
src_compile() {
- econf || die
+ econf "--with-wx-config=/usr/bin/wx-config"|| die
emake || die
}