summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-09-16 07:48:51 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-09-16 07:48:51 +0000
commitb4c8f75d13bfc934b17dbe468c8b51370950b095 (patch)
tree225ca90aaa0b4f3c8ef899d846d825cab60db522 /net-print/foomatic-db-engine/foomatic-db-engine-3.0.2.ebuild
parentx86 for security 64154 (diff)
downloadhistorical-b4c8f75d13bfc934b17dbe468c8b51370950b095.tar.gz
historical-b4c8f75d13bfc934b17dbe468c8b51370950b095.tar.bz2
historical-b4c8f75d13bfc934b17dbe468c8b51370950b095.zip
security bump, bug #64166
Diffstat (limited to 'net-print/foomatic-db-engine/foomatic-db-engine-3.0.2.ebuild')
-rw-r--r--net-print/foomatic-db-engine/foomatic-db-engine-3.0.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-print/foomatic-db-engine/foomatic-db-engine-3.0.2.ebuild b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.2.ebuild
new file mode 100644
index 000000000000..fd6dede80448
--- /dev/null
+++ b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/foomatic-db-engine-3.0.2.ebuild,v 1.1 2004/09/16 07:48:01 lanius Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="Foomatic printer database engine"
+HOMEPAGE="http://www.linuxprinting.org/foomatic"
+SRC_URI="http://www.linuxprinting.org/download/foomatic/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips ~ppc64"
+
+DEPEND="dev-libs/libxml2
+ net-misc/wget
+ net-misc/curl
+ net-print/foomatic-filters"
+
+src_compile() {
+ epatch ${FILESDIR}/perl-module-3.0.1.diff
+ econf || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ # install perl modules
+ cd lib
+ perl-module_src_prep
+ perl-module_src_compile
+ perl-module_src_test
+ perl-module_src_install
+}