summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-06 16:03:31 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-06 16:03:31 +0000
commit4f63eccee2fba72caacb8babf439eb7596000f44 (patch)
tree64607ff712b4d1fde2a2cfd8ec58dcec976c8db0 /net-print/foomatic-db-engine/foomatic-db-engine-4.0.7.ebuild
parentNon-maintainer Version Bump, notified by euscan (diff)
downloadhistorical-4f63eccee2fba72caacb8babf439eb7596000f44.tar.gz
historical-4f63eccee2fba72caacb8babf439eb7596000f44.tar.bz2
historical-4f63eccee2fba72caacb8babf439eb7596000f44.zip
Non-maintainer Version Bump, notified by euscan
Package-Manager: portage-2.2.0_alpha31/cvs/Linux x86_64
Diffstat (limited to 'net-print/foomatic-db-engine/foomatic-db-engine-4.0.7.ebuild')
-rw-r--r--net-print/foomatic-db-engine/foomatic-db-engine-4.0.7.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-print/foomatic-db-engine/foomatic-db-engine-4.0.7.ebuild b/net-print/foomatic-db-engine/foomatic-db-engine-4.0.7.ebuild
new file mode 100644
index 000000000000..62b4824a9361
--- /dev/null
+++ b/net-print/foomatic-db-engine/foomatic-db-engine-4.0.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/foomatic-db-engine-4.0.7.ebuild,v 1.1 2011/05/06 16:03:31 jlec Exp $
+
+EAPI="2"
+
+inherit eutils perl-app versionator
+
+DESCRIPTION="Generates ppds out of xml foomatic printer description files"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://www.linuxprinting.org/download/foomatic/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxml2
+ net-print/foomatic-filters"
+PDEPEND="net-print/foomatic-db"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-perl-module.patch \
+ "${FILESDIR}"/${PV}-respect-ldflag.patch
+ sed -i -e "s:@LIB_CUPS@:$(cups-config --serverbin):" "${S}"/Makefile.in
+}
+
+src_configure() {
+ default
+ emake defaults || die "emake defaults failed"
+
+ cd lib
+ perl-app_src_configure
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ cd lib
+ perl-app_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ cd lib
+ perl-module_src_install
+}
+
+src_test() {
+ cd lib
+ perl-module_src_test
+}