summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-13 05:17:14 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-13 05:17:14 +0000
commitcac736d759183e5b039b6644d3dce8d68df6cf34 (patch)
treea5950a96ab2aeaae76af09956c9e5ebe64bb0b89 /net-print/hpijs/hpijs-1.3.ebuild
parentadded the new stable build, marked as testing. depends on the latest linc (diff)
downloadhistorical-cac736d759183e5b039b6644d3dce8d68df6cf34.tar.gz
historical-cac736d759183e5b039b6644d3dce8d68df6cf34.tar.bz2
historical-cac736d759183e5b039b6644d3dce8d68df6cf34.zip
#10319
Diffstat (limited to 'net-print/hpijs/hpijs-1.3.ebuild')
-rw-r--r--net-print/hpijs/hpijs-1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-print/hpijs/hpijs-1.3.ebuild b/net-print/hpijs/hpijs-1.3.ebuild
new file mode 100644
index 000000000000..d59ad8563a95
--- /dev/null
+++ b/net-print/hpijs/hpijs-1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.3.ebuild,v 1.1 2002/11/13 05:17:14 woodchip Exp $
+
+# Though this program runs on it's own it makes no sense to run it without ghostscript
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The HP Inkjet server for Ghostscript. Provides best output for HP Inkjet Printers"
+HOMEPAGE="http://hpinkjet.sourceforge.net"
+KEYWORDS="~x86 ~ppc"
+SRC_URI="mirror://sourceforge/hpinkjet/${P}.tar.gz"
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND} app-text/ghostscript"
+LICENSE="as-is"
+SLOT="0"
+
+src_compile () {
+ econf --host=${CHOST} || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install () {
+ einstall || die
+ # fix the doc dir, it needs to have the package revision..
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+}
+
+pkg_postinst () {
+ if [ "`use cups`" ] ; then
+ einfo "To use the hpijs driver with the cups spooler, you will need the .ppd file"
+ einfo "for your printer. You may obtain it from:"
+ einfo "http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
+ einfo "Install it in /usr/share/cups/model. After restarting cups you should be"
+ einfo "able to use the new driver."
+ else
+ einfo "To use the hpijs driver with the PDQ spooler you will need the PDQ driver file"
+ einfo "for your printer from http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
+ einfo "This file should be installed in /etc/pdq/drivers"
+ fi
+}