summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 19:57:02 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 19:57:02 +0000
commita727b77e5c3b6cd50fa8220356c0cea00429e791 (patch)
tree2289fbc0cc765bc5434eb20321e78f6f2829b32d /net-print/pykota/pykota-1.25_p2437-r1.ebuild
parentx86 stable, bug #314899 (diff)
downloadhistorical-a727b77e5c3b6cd50fa8220356c0cea00429e791.tar.gz
historical-a727b77e5c3b6cd50fa8220356c0cea00429e791.tar.bz2
historical-a727b77e5c3b6cd50fa8220356c0cea00429e791.zip
Use Python 2 (bug #315873). Delete call to deprecated python_version().
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'net-print/pykota/pykota-1.25_p2437-r1.ebuild')
-rw-r--r--net-print/pykota/pykota-1.25_p2437-r1.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/net-print/pykota/pykota-1.25_p2437-r1.ebuild b/net-print/pykota/pykota-1.25_p2437-r1.ebuild
index fb60e4a6915e..8ca86c92d66e 100644
--- a/net-print/pykota/pykota-1.25_p2437-r1.ebuild
+++ b/net-print/pykota/pykota-1.25_p2437-r1.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/pykota-1.25_p2437-r1.ebuild,v 1.3 2009/11/29 13:51:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/pykota-1.25_p2437-r1.ebuild,v 1.4 2010/06/04 19:57:02 arfrever Exp $
-S=${WORKDIR}/${PN}
+EAPI="3"
+PYTHON_DEPEND="2"
-inherit python eutils distutils
+inherit distutils
-DESCRIPTION="Flexible print quota and accounting package for use with CUPS and
-lpd."
-SRC_URI="http://scriptkitty.com/files/${P}.tar.bz2"
+DESCRIPTION="Flexible print quota and accounting package for use with CUPS and lpd."
HOMEPAGE="http://www.pykota.com"
-LICENSE="GPL-2"
+SRC_URI="http://scriptkitty.com/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="ldap mysql postgres snmp sqlite snmp xml"
DEPEND="dev-lang/python
@@ -25,17 +27,19 @@ DEPEND="dev-lang/python
sqlite? ( =dev-python/pysqlite-2* )
snmp? ( net-analyzer/net-snmp =dev-python/pysnmp-3.4* )
xml? ( dev-python/jaxml )"
-
RDEPEND="${DEPEND}"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
+S="${WORKDIR}/${PN}"
DOCS="README MANIFEST.in TODO SECURITY NEWS CREDITS FAQ"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_install() {
mkdir -p "${D}"/etc/${PN}
- python_version
distutils_src_install
#cups backend ----------------------------------------------
mkdir -p "${D}"$(cups-config --serverbin)/backend