summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-27 03:17:56 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-27 03:17:56 +0000
commit2b37f543fd6c30bec6463262e12ead03f56b4c86 (patch)
tree36615f64b25d02519d98ae6b3727bc83622040f3 /net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild
parentFix typo in description (diff)
downloadhistorical-2b37f543fd6c30bec6463262e12ead03f56b4c86.tar.gz
historical-2b37f543fd6c30bec6463262e12ead03f56b4c86.tar.bz2
historical-2b37f543fd6c30bec6463262e12ead03f56b4c86.zip
Fix some compiler warnings. Set RDEPEND.
Package-Manager: portage-2.2.0_alpha1/cvs/Linux i686
Diffstat (limited to 'net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild')
-rw-r--r--net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild b/net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild
new file mode 100644
index 000000000000..d4078679037e
--- /dev/null
+++ b/net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild,v 1.1 2010/10/27 03:17:56 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="The dnsproxy daemon is a proxy for DNS queries"
+HOMEPAGE="http://www.wolfermann.org/dnsproxy.html"
+SRC_URI="http://www.wolfermann.org/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_configure() {
+ append-flags -D_GNU_SOURCE
+ econf --with-native-libevent || die "econf failed"
+}
+
+src_compile() {
+ emake dnsproxy || die "make failed"
+}
+
+src_install() {
+ dosbin dnsproxy
+ keepdir /var/empty
+
+ newconfd "${FILESDIR}"/dnsproxy.confd dnsproxy
+ newinitd "${FILESDIR}"/dnsproxy.initd dnsproxy
+ insinto /etc/dnsproxy
+ newins dnsproxy.conf dnsproxy.conf.dist
+
+ dodoc README
+ doman dnsproxy.1
+}