summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-05-06 08:04:07 +0000
committerAlin Năstac <mrness@gentoo.org>2006-05-06 08:04:07 +0000
commit5626d7dfe18a7d5d03b284b4e77860d497ebd30a (patch)
tree440e645ed7684acf75ee8a6b5250b3f2b3946629 /net-proxy/wwwoffle
parentFix uniconfd.ini path (#132188) (diff)
downloadhistorical-5626d7dfe18a7d5d03b284b4e77860d497ebd30a.tar.gz
historical-5626d7dfe18a7d5d03b284b4e77860d497ebd30a.tar.bz2
historical-5626d7dfe18a7d5d03b284b4e77860d497ebd30a.zip
Take over the maintainership and fix broken compilation when build using gcc-41 on amd64 arch (#131070).
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-proxy/wwwoffle')
-rw-r--r--net-proxy/wwwoffle/ChangeLog7
-rw-r--r--net-proxy/wwwoffle/Manifest15
-rw-r--r--net-proxy/wwwoffle/files/wwwoffle-2.9-gcc41.patch43
-rw-r--r--net-proxy/wwwoffle/metadata.xml4
-rw-r--r--net-proxy/wwwoffle/wwwoffle-2.9.ebuild3
5 files changed, 61 insertions, 11 deletions
diff --git a/net-proxy/wwwoffle/ChangeLog b/net-proxy/wwwoffle/ChangeLog
index c95a3bc11316..f80984f51de8 100644
--- a/net-proxy/wwwoffle/ChangeLog
+++ b/net-proxy/wwwoffle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/wwwoffle
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.9 2006/04/14 12:34:30 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.10 2006/05/06 08:04:07 mrness Exp $
+
+ 06 May 2006; Alin Nastac <mrness@gentoo.org>
+ +files/wwwoffle-2.9-gcc41.patch, metadata.xml, wwwoffle-2.9.ebuild:
+ Take over the maintainership and fix broken compilation when build using
+ gcc-41 on amd64 arch (#131070).
*wwwoffle-2.9 (14 Apr 2006)
diff --git a/net-proxy/wwwoffle/Manifest b/net-proxy/wwwoffle/Manifest
index 70869e32bdce..0c28438bbbc5 100644
--- a/net-proxy/wwwoffle/Manifest
+++ b/net-proxy/wwwoffle/Manifest
@@ -1,19 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 009f32d02c222ac0b300a7758dd77987 ChangeLog 7283
+MD5 ab4f5f4a4a44358410b90d0feb16a73b ChangeLog 7511
MD5 a627d44111b7ff1d162ac248f5c35376 files/digest-wwwoffle-2.8e 63
MD5 cebdf87d07b34aa39e54896936f18eab files/digest-wwwoffle-2.9 62
+MD5 81b9c9d0eaf6200078fdb1380202de80 files/wwwoffle-2.9-gcc41.patch 1728
MD5 848cabe3390aa24c7aea9d08c8d1d937 files/wwwoffle-online.confd 426
MD5 f710c01ec4b28de6014c40ee7f4f6046 files/wwwoffle-online.initd 696
MD5 9976f6cc21d8fd01b67cb72fc7cf3198 files/wwwoffle.initd 539
-MD5 2f092f7d958b226c98713d29cff08f9d metadata.xml 502
+MD5 3acc1c195150e4b1528fc86076e4f292 metadata.xml 496
MD5 b32055c6ea5422b6186b09203a4315e2 wwwoffle-2.8e.ebuild 5140
-MD5 c2610a4d885521cc16f354895cfb556c wwwoffle-2.9.ebuild 5251
+MD5 c6c15a7e293d42264201335a0c907605 wwwoffle-2.9.ebuild 5290
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
+Version: GnuPG v1.4.2.2 (GNU/Linux)
-iD8DBQFEP5gTjG8pv1lIUX4RAmIpAKCfQVVhb+hQtBsHT+3arDaTaHNc+wCdGied
-BW0/XOiY8Z+qauqEbKs55Us=
-=DpvK
+iD8DBQFEXFiCjG8pv1lIUX4RAj0VAJ9XHity9pcKWhL1TyM9/SE+Nd2fCACgqmpZ
+0vktbFv1y8MZDY24fpx4UGU=
+=QYOs
-----END PGP SIGNATURE-----
diff --git a/net-proxy/wwwoffle/files/wwwoffle-2.9-gcc41.patch b/net-proxy/wwwoffle/files/wwwoffle-2.9-gcc41.patch
new file mode 100644
index 000000000000..bd9e6291230c
--- /dev/null
+++ b/net-proxy/wwwoffle/files/wwwoffle-2.9-gcc41.patch
@@ -0,0 +1,43 @@
+diff -ur wwwoffle-2.9-orig/src/proto.h wwwoffle-2.9/src/proto.h
+--- wwwoffle-2.9-orig/src/proto.h 2006-05-02 01:06:01.316639546 +0000
++++ wwwoffle-2.9/src/proto.h 2006-05-02 01:13:24.080901246 +0000
+@@ -62,7 +62,7 @@
+ char /*@null@*/ /*@only@*/ *HTTP_Open(URL *Url);
+ char /*@null@*/ /*@only@*/ *HTTP_Request(URL *Url,Header *request_head,Body *request_body);
+ int HTTP_ReadHead(/*@out@*/ Header **reply_head);
+-int HTTP_ReadBody(char *s,size_t n);
++ssize_t HTTP_ReadBody(char *s,size_t n);
+ int HTTP_Close(void);
+
+ #if USE_GNUTLS
+@@ -82,7 +82,7 @@
+ char /*@null@*/ /*@only@*/ *FTP_Open(URL *Url);
+ char /*@null@*/ /*@only@*/ *FTP_Request(URL *Url,Header *request_head,Body *request_body);
+ int FTP_ReadHead(/*@out@*/ Header **reply_head);
+-int FTP_ReadBody(char *s,size_t n);
++ssize_t FTP_ReadBody(char *s,size_t n);
+ int FTP_Close(void);
+
+ /* In finger.c */
+@@ -90,7 +90,7 @@
+ char /*@null@*/ /*@only@*/ *Finger_Open(URL *Url);
+ char /*@null@*/ /*@only@*/ *Finger_Request(URL *Url,Header *request_head,Body *request_body);
+ int Finger_ReadHead(/*@out@*/ Header **reply_head);
+-int Finger_ReadBody(char *s,size_t n);
++ssize_t Finger_ReadBody(char *s,size_t n);
+ int Finger_Close(void);
+
+ /* In ssl.c */
+diff -ur wwwoffle-2.9-orig/src/wwwoffles.c wwwoffle-2.9/src/wwwoffles.c
+--- wwwoffle-2.9-orig/src/wwwoffles.c 2006-05-02 01:06:01.316639546 +0000
++++ wwwoffle-2.9/src/wwwoffles.c 2006-05-02 01:07:33.428854807 +0000
+@@ -3026,7 +3026,7 @@
+ This function is used as a callback from gifmodify.c and htmlmodify.l
+ ++++++++++++++++++++++++++++++++++++++*/
+
+-int wwwoffles_read_data(char *data,size_t len)
++ssize_t wwwoffles_read_data(char *data,size_t len)
+ {
+ if(modify_err==-1)
+ return(0);
+
diff --git a/net-proxy/wwwoffle/metadata.xml b/net-proxy/wwwoffle/metadata.xml
index fdcfd741744c..1e20ba2eb6ae 100644
--- a/net-proxy/wwwoffle/metadata.xml
+++ b/net-proxy/wwwoffle/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>net-proxy</herd>
<maintainer>
- <email>dragonheart@gentoo.org</email>
- <name>Daniel Black</name>
+ <email>mrness@gentoo.org</email>
+ <name>Alin Nastac</name>
</maintainer>
<longdescription>The wwwoffled program is a simple proxy server with special features for use
with dial-up internet links. This means that it is possible to browse web pages and read them
diff --git a/net-proxy/wwwoffle/wwwoffle-2.9.ebuild b/net-proxy/wwwoffle/wwwoffle-2.9.ebuild
index 38914b41bc3d..030e8bb14ac0 100644
--- a/net-proxy/wwwoffle/wwwoffle-2.9.ebuild
+++ b/net-proxy/wwwoffle/wwwoffle-2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9.ebuild,v 1.2 2006/04/14 12:39:33 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9.ebuild,v 1.3 2006/05/06 08:04:07 mrness Exp $
inherit eutils
@@ -30,6 +30,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ epatch "${FILESDIR}/${P}-gcc41.patch"
sed -i -e 's#$(TAR) xpf #$(TAR) --no-same-owner -xpf #' \
"${S}/cache/Makefile.in"
}