summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-05-27 19:57:22 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-05-27 19:57:22 +0000
commitfc7e9a58f441682fd8be92017ab38bc968393271 (patch)
tree128e6485c5f7794e11ea1c30be58cf74d681d4a5 /net-wireless/hostapd
parentVersion bump, but only for people using kernels older than linux-2.6.14. (diff)
downloadhistorical-fc7e9a58f441682fd8be92017ab38bc968393271.tar.gz
historical-fc7e9a58f441682fd8be92017ab38bc968393271.tar.bz2
historical-fc7e9a58f441682fd8be92017ab38bc968393271.zip
Version bump.
Package-Manager: portage-2.0.54-r2
Diffstat (limited to 'net-wireless/hostapd')
-rw-r--r--net-wireless/hostapd/ChangeLog9
-rw-r--r--net-wireless/hostapd/files/digest-hostapd-0.4.91
-rw-r--r--net-wireless/hostapd/files/hostapd-0.4.9-conf.d9
-rw-r--r--net-wireless/hostapd/files/hostapd-0.4.9-init.d50
-rw-r--r--net-wireless/hostapd/hostapd-0.4.9.ebuild117
5 files changed, 185 insertions, 1 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index 8f23ddc297b8..5cc3668fe6d3 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/hostapd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.63 2006/04/29 14:25:13 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.64 2006/05/27 19:57:22 brix Exp $
+
+*hostapd-0.4.9 (27 May 2006)
+
+ 27 May 2006; Henrik Brix Andersen <brix@gentoo.org>
+ +files/hostapd-0.4.9-conf.d, +files/hostapd-0.4.9-init.d,
+ +hostapd-0.4.9.ebuild:
+ Version bump.
*hostapd-0.5.3 (29 Apr 2006)
diff --git a/net-wireless/hostapd/files/digest-hostapd-0.4.9 b/net-wireless/hostapd/files/digest-hostapd-0.4.9
new file mode 100644
index 000000000000..0de1901df547
--- /dev/null
+++ b/net-wireless/hostapd/files/digest-hostapd-0.4.9
@@ -0,0 +1 @@
+MD5 3feba72240c24024b44fcd0b66f7c5d2 hostapd-0.4.9.tar.gz 291630
diff --git a/net-wireless/hostapd/files/hostapd-0.4.9-conf.d b/net-wireless/hostapd/files/hostapd-0.4.9-conf.d
new file mode 100644
index 000000000000..7d05735eb3b4
--- /dev/null
+++ b/net-wireless/hostapd/files/hostapd-0.4.9-conf.d
@@ -0,0 +1,9 @@
+# Space separated List of interfaces which needs to be started before
+# hostapd
+INTERFACES="wlan0"
+
+# Space separated list of configuration files
+CONFIGS="/etc/hostapd/hostapd.conf"
+
+# Extra options to pass to hostapd, see hostapd(8)
+OPTIONS=""
diff --git a/net-wireless/hostapd/files/hostapd-0.4.9-init.d b/net-wireless/hostapd/files/hostapd-0.4.9-init.d
new file mode 100644
index 000000000000..23784004d3d4
--- /dev/null
+++ b/net-wireless/hostapd/files/hostapd-0.4.9-init.d
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/files/hostapd-0.4.9-init.d,v 1.1 2006/05/27 19:57:22 brix Exp $
+
+opts="start stop reload"
+
+depend() {
+ local iface
+
+ for iface in ${INTERFACES}; do
+ need net.${iface}
+ done
+
+ use logger
+}
+
+checkconfig() {
+ local file
+
+ for file in ${CONFIGS}; do
+ if [[ ! -r ${file} ]]; then
+ eerror "hostapd configuration file (${CONFIG}) not found"
+ return 1
+ fi
+ done
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting hostapd"
+ start-stop-daemon --start --exec /usr/sbin/hostapd \
+ -- -B ${OPTIONS} ${CONFIGS}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping hostapd"
+ start-stop-daemon --stop --exec /usr/sbin/hostapd
+ eend ${?}
+}
+
+reload() {
+ checkconfig || return 1
+
+ ebegin "Reloading hostapd configuration"
+ kill -HUP $(pidof /usr/sbin/hostapd) > /dev/null 2>&1
+ eend ${?}
+}
diff --git a/net-wireless/hostapd/hostapd-0.4.9.ebuild b/net-wireless/hostapd/hostapd-0.4.9.ebuild
new file mode 100644
index 000000000000..dc0e5ff1b8aa
--- /dev/null
+++ b/net-wireless/hostapd/hostapd-0.4.9.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.4.9.ebuild,v 1.1 2006/05/27 19:57:22 brix Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="IEEE 802.11 wireless LAN Host AP daemon"
+HOMEPAGE="http://hostap.epitest.fi"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="ipv6 logwatch madwifi ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ madwifi? ( || ( net-wireless/madwifi-ng net-wireless/madwifi-old ) )"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_unpack() {
+ local CONFIG=${S}/.config
+
+ unpack ${A}
+
+ sed -i -e "s:/etc/hostapd:/etc/hostapd/hostapd:g" \
+ ${S}/hostapd.conf
+
+ # toolchain setup
+ echo "CC = $(tc-getCC)" > ${CONFIG}
+
+ # authentication methods
+ echo "CONFIG_EAP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_MD5=y" >> ${CONFIG}
+ echo "CONFIG_EAP_GTC=y" >> ${CONFIG}
+ echo "CONFIG_IAPP=y" >> ${CONFIG}
+ echo "CONFIG_PKCS12=y" >> ${CONFIG}
+ echo "CONFIG_RADIUS_SERVER=y" >> ${CONFIG}
+ echo "CONFIG_RSN_PREAUTH=y" >> ${CONFIG}
+ echo "CONFIG_EAP_SIM=y" >> ${CONFIG}
+
+ if use ssl; then
+ # SSL authentication methods
+ echo "CONFIG_EAP_MSCHAPV2=y" >> ${CONFIG}
+ echo "CONFIG_EAP_PEAP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TLS=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TTLS=y" >> ${CONFIG}
+ fi
+
+ if use ipv6; then
+ echo "CONFIG_IPV6=y" >> ${CONFIG}
+ fi
+
+ # Linux specific drivers
+ echo "CONFIG_DRIVER_HOSTAP=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_WIRED=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_PRISM54=y" >> ${CONFIG}
+
+ if use madwifi; then
+ # Add include path for madwifi-driver headers
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ fi
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /etc/hostapd
+ doins hostapd.conf hostapd.accept hostapd.deny \
+ hostapd.eap_user hostapd.radius_clients hostapd.sim_db hostapd.wpa_psk
+
+ dosbin hostapd
+ dobin hostapd_cli
+
+ newinitd ${FILESDIR}/${P}-init.d hostapd
+ newconfd ${FILESDIR}/${P}-conf.d hostapd
+
+ doman hostapd.8 hostapd_cli.1
+
+ dodoc ChangeLog developer.txt README
+
+ docinto examples
+ dodoc madwifi.conf wired.conf
+
+ if use logwatch; then
+ insinto /etc/log.d/conf/services/
+ doins logwatch/hostapd.conf
+
+ exeinto /etc/log.d/scripts/services/
+ doexe logwatch/hostapd
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "In order to use ${PN} you need to set up your wireless card"
+ einfo "for master mode in /etc/conf.d/net or /etc/conf.d/wireless"
+ einfo "and then start /etc/init.d/hostapd."
+ einfo
+ einfo "Example configuration:"
+ einfo
+ einfo "config_wlan0=( \"192.168.1.1/24\" )"
+ einfo "channel_wlan0=\"6\""
+ einfo "essid_wlan0=\"test\""
+ einfo "mode_wlan0=\"master\""
+ einfo
+ if use madwifi; then
+ einfo "This package now compiles against the headers installed by"
+ einfo "the madwifi driver. You should remerge ${PN} after"
+ einfo "upgrading your madwifi driver."
+ einfo
+ fi
+}