summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-03-29 16:46:45 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-03-29 16:46:45 +0000
commit9c5c7cabbc0c7f33e9d40a41cc68338d3a68a555 (patch)
treec91443ea74eee7fdc9bca8aa8d20eea22aba89e6 /net-wireless/pyrit/pyrit-0.4.0.ebuild
parentVersion bump #409651 by Tomáš Chvátal. (diff)
downloadhistorical-9c5c7cabbc0c7f33e9d40a41cc68338d3a68a555.tar.gz
historical-9c5c7cabbc0c7f33e9d40a41cc68338d3a68a555.tar.bz2
historical-9c5c7cabbc0c7f33e9d40a41cc68338d3a68a555.zip
Add pyrit with opencl and cuda plugins, thanks to Oleg Kravchenko <oleg@kaa.org.ua>. Bugs 309815, 309817, 309813.
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'net-wireless/pyrit/pyrit-0.4.0.ebuild')
-rw-r--r--net-wireless/pyrit/pyrit-0.4.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-wireless/pyrit/pyrit-0.4.0.ebuild b/net-wireless/pyrit/pyrit-0.4.0.ebuild
new file mode 100644
index 000000000000..0aa4cabdd64a
--- /dev/null
+++ b/net-wireless/pyrit/pyrit-0.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/pyrit/pyrit-0.4.0.ebuild,v 1.1 2012/03/29 16:46:45 maksbotan Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="GPU-accelerated attack against WPA-PSK authentication"
+HOMEPAGE="http://code.google.com/p/pyrit/"
+SRC_URI="http://pyrit.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cuda opencl test"
+
+DEPEND="dev-libs/openssl
+ net-libs/libpcap
+ test? ( >=net-analyzer/scapy-2 )"
+RDEPEND=">=net-analyzer/scapy-2
+ opencl? ( net-wireless/cpyrit-opencl )
+ cuda? ( net-wireless/cpyrit-cuda )"
+
+src_test() {
+ cd test
+ testing() {
+ PYTHONPATH=$(ls -d "${S}"/build-${PYTHON_ABI}/lib*) $(PYTHON) test_pyrit.py
+ }
+ python_execute_function testing
+}