summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2004-02-09 00:32:54 +0000
committerWolfram Schlich <wschlich@gentoo.org>2004-02-09 00:32:54 +0000
commite3cab7667dd85421491d10522d6315e52cd20f9e (patch)
treed96a9d2d63bf68a1442a7c6ea0e7b02262d11051 /net-wireless
parentversion bump (diff)
downloadhistorical-e3cab7667dd85421491d10522d6315e52cd20f9e.tar.gz
historical-e3cab7667dd85421491d10522d6315e52cd20f9e.tar.bz2
historical-e3cab7667dd85421491d10522d6315e52cd20f9e.zip
version bump
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostapd/Manifest4
-rw-r--r--net-wireless/hostapd/files/digest-hostapd-0.1.31
-rw-r--r--net-wireless/hostapd/hostapd-0.1.3.ebuild39
3 files changed, 42 insertions, 2 deletions
diff --git a/net-wireless/hostapd/Manifest b/net-wireless/hostapd/Manifest
index 336721615f30..66cdf93ed05f 100644
--- a/net-wireless/hostapd/Manifest
+++ b/net-wireless/hostapd/Manifest
@@ -1,7 +1,7 @@
-MD5 4e2d5d6f79cf398cdc3c69044e72da5b ChangeLog 681
+MD5 edfbf6ade6eb6ed4b52667fa70fd666b ChangeLog 681
MD5 e7ebae5af10ec06f5ede99216b1337dc hostapd-0.1.0.ebuild 1079
MD5 b852e83aa853d08d6f30ce4a89bf557d metadata.xml 461
-MD5 62cedd4700d20e5f99bb63ba2612e9ff hostapd-0.1.3.ebuild 1086
+MD5 19c481e99b15d34fbf7794bf82c9d7fb hostapd-0.1.3.ebuild 1086
MD5 cf287b50f0ccd832a08fb3031281cd4f files/hostapd.init.d 858
MD5 ebaf0a97df860deb10127e44d8c9f4de files/digest-hostapd-0.1.0 64
MD5 7c806d26277486d29515a6658707a2fe files/digest-hostapd-0.1.3 64
diff --git a/net-wireless/hostapd/files/digest-hostapd-0.1.3 b/net-wireless/hostapd/files/digest-hostapd-0.1.3
new file mode 100644
index 000000000000..2d8b048f9504
--- /dev/null
+++ b/net-wireless/hostapd/files/digest-hostapd-0.1.3
@@ -0,0 +1 @@
+MD5 54563fb51f143c4bf26ddec2516e8f9f hostapd-0.1.3.tar.gz 85160
diff --git a/net-wireless/hostapd/hostapd-0.1.3.ebuild b/net-wireless/hostapd/hostapd-0.1.3.ebuild
new file mode 100644
index 000000000000..2c824cd4c0d4
--- /dev/null
+++ b/net-wireless/hostapd/hostapd-0.1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.1.3.ebuild,v 1.1 2004/02/09 00:32:43 wschlich Exp $
+
+inherit eutils
+
+DESCRIPTION="HostAP wireless daemon"
+HOMEPAGE="http://hostap.epitest.fi/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=net-wireless/hostap-driver-0.1.0"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ emake CC="${CC}" CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ diropts -o root -g root -m 0750
+ dodir /etc/hostapd
+ insopts -o root -g root -m 0640
+ insinto /etc/hostapd
+ exeopts ""
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/hostapd.init.d" hostapd
+ doins \
+ hostapd.conf \
+ hostapd.accept \
+ hostapd.deny
+ dosed 's:\(accept_mac_file=\)/etc/hostapd.accept:\1/etc/hostapd/hostapd.accept:g' /etc/hostapd/hostapd.conf
+ dosed 's:\(deny_mac_file=\)/etc/hostapd.deny:\1/etc/hostapd/hostapd.deny:g' /etc/hostapd/hostapd.conf
+ dosbin hostapd
+ dodoc \
+ README \
+ developer.txt
+}