summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-07-11 19:53:56 +0000
committerStuart Herbert <stuart@gentoo.org>2004-07-11 19:53:56 +0000
commitdef23ee651e5c69ad26ff959f16f200cbd89a6b1 (patch)
tree60fe79cb6751fb94eb5da127b474449fe4b377a1 /net-www/dotproject
parentFix bogus prefix in ijs-config. (diff)
downloadhistorical-def23ee651e5c69ad26ff959f16f200cbd89a6b1.tar.gz
historical-def23ee651e5c69ad26ff959f16f200cbd89a6b1.tar.bz2
historical-def23ee651e5c69ad26ff959f16f200cbd89a6b1.zip
Initial import
Diffstat (limited to 'net-www/dotproject')
-rw-r--r--net-www/dotproject/ChangeLog11
-rw-r--r--net-www/dotproject/Manifest6
-rw-r--r--net-www/dotproject/dotproject-1.0.2.ebuild33
-rw-r--r--net-www/dotproject/files/1.0.2/install-en.txt31
-rw-r--r--net-www/dotproject/files/1.0.2/postinstall.sh9
-rw-r--r--net-www/dotproject/files/digest-dotproject-1.0.21
-rw-r--r--net-www/dotproject/metadata.xml10
7 files changed, 101 insertions, 0 deletions
diff --git a/net-www/dotproject/ChangeLog b/net-www/dotproject/ChangeLog
new file mode 100644
index 000000000000..ab5370e75e92
--- /dev/null
+++ b/net-www/dotproject/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-www/dotproject
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/dotproject/ChangeLog,v 1.1 2004/07/11 19:53:56 stuart Exp $
+
+*dotproject-1.0.2 (11 Jul 2004)
+
+ 11 Jul 2004; Stuart Herbert <stuart@gentoo.org> +metadata.xml,
+ +files/1.0.2/install-en.txt, +files/1.0.2/postinstall.sh,
+ +dotproject-1.0.2.ebuild:
+ Initial import
+
diff --git a/net-www/dotproject/Manifest b/net-www/dotproject/Manifest
new file mode 100644
index 000000000000..0ae79246d9cf
--- /dev/null
+++ b/net-www/dotproject/Manifest
@@ -0,0 +1,6 @@
+MD5 896fd6c6cf1cc17017d444061bb19d7e dotproject-1.0.2.ebuild 913
+MD5 88b2c84c1b3552228d711637cb7d9269 metadata.xml 274
+MD5 229ab201f3aa1bd787e3f5165de99d0c ChangeLog 413
+MD5 c31cbdbd8f336b876284208f18c75c30 files/digest-dotproject-1.0.2 70
+MD5 d7249d4eb677c96cb5cda527a66dc333 files/1.0.2/install-en.txt 815
+MD5 422ed5a572051eeefd96067df44bc1f8 files/1.0.2/postinstall.sh 176
diff --git a/net-www/dotproject/dotproject-1.0.2.ebuild b/net-www/dotproject/dotproject-1.0.2.ebuild
new file mode 100644
index 000000000000..4aa7400e9643
--- /dev/null
+++ b/net-www/dotproject/dotproject-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/dotproject/dotproject-1.0.2.ebuild,v 1.1 2004/07/11 19:53:56 stuart Exp $
+
+inherit webapp
+
+MY_P="${PN}_${PV}-1"
+MY_SQL_PV="${PV//\./}"
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://www.dotproject.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+KEYWORDS="-x86"
+DEPEND="$DEPEND"
+RDEPEND="$RDEPEND"
+S=${WORKDIR}/${PN}
+LICENSE="BSD"
+
+src_install ()
+{
+ webapp_src_preinst
+
+ mv includes/config-dist.php includes/config.php
+ cp -R * ${D}${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/includes/config.php
+ webapp_serverowned ${MY_HTDOCSDIR}/files
+
+ webapp_sqlscript mysql db/${PN}_${MY_SQL_PV}.sql
+ webapp_postinst_txt en ${FILESDIR}/${PVR}/install-en.txt
+ webapp_hook_script ${FILESDIR}/${PVR}/postinstall.sh
+
+ webapp_src_install
+}
diff --git a/net-www/dotproject/files/1.0.2/install-en.txt b/net-www/dotproject/files/1.0.2/install-en.txt
new file mode 100644
index 000000000000..1b41961cf318
--- /dev/null
+++ b/net-www/dotproject/files/1.0.2/install-en.txt
@@ -0,0 +1,31 @@
+To complete your installation ...
+=================================
+
+1. Create a new database for dotproject in mysql:
+
+ mysql> CREATE DATABASE dotpoject;
+ mysql> GRANT ALL PRIVILEGES ON dotproject.*
+ TO dotproject@localhost IDENTIFIED BY
+ "yourpassword" WITH GRANT OPTION
+
+2. Edit the configuration file
+
+ ${MY_INSTALLDIR}/includes/config.php
+
+ You need to set 'dbuser' and 'dbpass' for sure. You will probably want
+ to edit 'company_name', 'page_title', 'base_url' and 'site_domain' too.
+
+2. Run the script:
+
+ bash$ mysql dotproject < ${MY_SQLSCRIPTSDIR}/mysql/${PVR}_create.sql
+
+3. Point your web browser at:
+
+ http://${VHOST_HOSTNAME}/${MY_INSTALLDIR}/
+
+ You should see a login page.
+
+ Username: admin
+ Password: passwd
+
+4. Once you're in, change the admin password as soon as possible!
diff --git a/net-www/dotproject/files/1.0.2/postinstall.sh b/net-www/dotproject/files/1.0.2/postinstall.sh
new file mode 100644
index 000000000000..a34d4664b634
--- /dev/null
+++ b/net-www/dotproject/files/1.0.2/postinstall.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+case "$1" in
+ install)
+ sed -i "s|C:/apache/htdocs/dotproject|${MY_INSTALLDIR}|g;" ${MY_INSTALLDIR}/includes/config.php
+ ;;
+
+ # nothing to do when we clean
+esac
diff --git a/net-www/dotproject/files/digest-dotproject-1.0.2 b/net-www/dotproject/files/digest-dotproject-1.0.2
new file mode 100644
index 000000000000..76ecb6974af9
--- /dev/null
+++ b/net-www/dotproject/files/digest-dotproject-1.0.2
@@ -0,0 +1 @@
+MD5 2df987207a907aad5f9fd699905f6dd4 dotproject_1.0.2-1.tar.gz 611275
diff --git a/net-www/dotproject/metadata.xml b/net-www/dotproject/metadata.xml
new file mode 100644
index 000000000000..118b90e92ffc
--- /dev/null
+++ b/net-www/dotproject/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>web-apps</herd>
+<maintainer>
+ <email>stuart@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+</pkgmetadata>