summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-09-01 12:29:01 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-09-01 12:29:01 +0000
commit7328bdde11c6ca5d51a8b360806a006c4bcfaf86 (patch)
tree1b4f7930150398cb98d0b8ddc4a88d178285b4fe /net-www/gnash
parentdrop old versions that use the deprecated pcmcia eclass and hppa keyword than... (diff)
downloadhistorical-7328bdde11c6ca5d51a8b360806a006c4bcfaf86.tar.gz
historical-7328bdde11c6ca5d51a8b360806a006c4bcfaf86.tar.bz2
historical-7328bdde11c6ca5d51a8b360806a006c4bcfaf86.zip
rename as per bug 143320
Package-Manager: portage-2.1.1_rc1-r2
Diffstat (limited to 'net-www/gnash')
-rw-r--r--net-www/gnash/ChangeLog8
-rw-r--r--net-www/gnash/files/digest-gnash-0.7.1_p200999991
-rw-r--r--net-www/gnash/gnash-0.7.1_p20099999.ebuild113
3 files changed, 121 insertions, 1 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index 701745db01a5..18ac70b0b38f 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.19 2006/08/14 15:28:19 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.20 2006/09/01 12:29:01 genstef Exp $
+
+*gnash-0.7.1_p20099999 (01 Sep 2006)
+
+ 01 Sep 2006; Stefan Schweizer <genstef@gentoo.org>
+ -gnash-0.7.1_p20090909.ebuild, +gnash-0.7.1_p20099999.ebuild:
+ rename as per bug 143320
*gnash-0.7.1_p20060814 (14 Aug 2006)
diff --git a/net-www/gnash/files/digest-gnash-0.7.1_p20099999 b/net-www/gnash/files/digest-gnash-0.7.1_p20099999
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/net-www/gnash/files/digest-gnash-0.7.1_p20099999
@@ -0,0 +1 @@
+
diff --git a/net-www/gnash/gnash-0.7.1_p20099999.ebuild b/net-www/gnash/gnash-0.7.1_p20099999.ebuild
new file mode 100644
index 000000000000..489949849e50
--- /dev/null
+++ b/net-www/gnash/gnash-0.7.1_p20099999.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.1_p20099999.ebuild,v 1.1 2006/09/01 12:29:01 genstef Exp $
+
+inherit nsplugins kde-functions autotools cvs
+
+DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
+HOMEPAGE="http://www.gnu.org/software/gnash"
+#SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${PV}/${P}.tar.bz2"
+ECVS_SERVER="cvs.sv.gnu.org:/sources/${PN}"
+ECVS_MODULE="${PN}"
+[ "${PV/0.7.1_p}" != "20099999" ] && ECVS_CO_OPTS="-D ${PV/0.7.1_p}"
+ECVS_UP_OPTS="-dP ${ECVS_CO_OPTS}"
+S=${WORKDIR}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+IUSE="gstreamer mad nsplugin nptl xml kde video_cards_i810"
+#dmalloc, broken see bug 142939
+#dmalloc? ( dev-libs/dmalloc )
+# $(use_enable dmalloc) \
+
+RDEPEND="
+ xml? ( dev-libs/libxml2 )
+ kde? (
+ kde-base/kdelibs
+ x11-libs/qt
+ )
+ sys-libs/zlib
+ media-libs/jpeg
+ mad? ( media-libs/libmad )
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl
+ net-misc/curl
+ virtual/opengl
+ || (
+ ( x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-proto/xproto )
+ virtual/x11
+ )
+ gstreamer? ( media-libs/gstreamer )
+ !gstreamer? ( media-libs/sdl-mixer )
+ dev-libs/atk
+ dev-libs/glib
+ >x11-libs/gtk+-2
+ x11-libs/pango
+ x11-libs/gtkglext"
+ #cairo? ( x11-libs/cairo )
+
+set-kdedir
+
+src_unpack() {
+ cvs_src_unpack
+ cd ${S}
+
+ # enable sound by default
+ ssed="bool.*do_sound[ \t]*=[ \t]*"
+ grep "${ssed}" . -rl | xargs \
+ sed -i -e "s:\(${ssed}\)false:\1true:"
+
+ AT_M4DIR="macros" eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ use nsplugin && myconf="${myconf} --enable-plugin --with-plugindir=/opt/netscape/plugins"
+
+ #--enable-renderer=engine Specify rendering engine:
+ # OpenGL (default)
+ # Cairo (experimental)
+ #cairo: does not work for plugins yet, offers flash for non-accelerated gfx?
+ #if use cairo; then
+ # myconf="${myconf} --enable-renderer=cairo"
+ #fi
+ #--enable-gui=flavor Specify gui flavor:
+ # GTK
+ # SDL -> has no controls, we do not USE it
+ #$(use_enable gtk glext) with USE=-gtk, fails to detect gtkglext, bug 135010
+ #--enable-sound=gst,sdl
+ if use gstreamer; then
+ myconf="${myconf} --enable-sound=gst"
+ else
+ myconf="${myconf} --enable-sound=sdl"
+ fi
+
+ econf \
+ $(use_enable kde klash) \
+ $(use_enable mad mp3) \
+ $(use_enable nptl pthreads) \
+ $(use_enable xml) \
+ $(use_enable video_cards_i810 i810-lod-bias) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ use nsplugin && inst_plugin /opt/netscape/plugins/libgnashplugin.so \
+ || rm -rf ${D}/opt
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "ALPHA"
+ ewarn "gnash is still in heavy development"
+ ewarn "please report gnash bugs upstream to the gnash devs"
+}