summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-04-08 21:50:17 +0000
committerDean Bailey <alron@gentoo.org>2003-04-08 21:50:17 +0000
commit3a9c1c7d1c652c4fb50e3fe719c3c65626e60214 (patch)
tree60dbbf968be3abf4d2182bc647ed80db4d9002e8 /net-www/horde-chora
parentupdated (diff)
downloadhistorical-3a9c1c7d1c652c4fb50e3fe719c3c65626e60214.tar.gz
historical-3a9c1c7d1c652c4fb50e3fe719c3c65626e60214.tar.bz2
historical-3a9c1c7d1c652c4fb50e3fe719c3c65626e60214.zip
revision bump to fix annoying pear issue
Diffstat (limited to 'net-www/horde-chora')
-rw-r--r--net-www/horde-chora/ChangeLog6
-rw-r--r--net-www/horde-chora/files/digest-horde-chora-1.2-r11
-rw-r--r--net-www/horde-chora/horde-chora-1.2-r1.ebuild55
3 files changed, 61 insertions, 1 deletions
diff --git a/net-www/horde-chora/ChangeLog b/net-www/horde-chora/ChangeLog
index 6e1bb1055e16..399882d51bad 100644
--- a/net-www/horde-chora/ChangeLog
+++ b/net-www/horde-chora/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/horde-chora
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-chora/ChangeLog,v 1.6 2003/02/12 08:47:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-chora/ChangeLog,v 1.7 2003/04/08 21:50:17 alron Exp $
+
+*horde-chora-1.2-r1 (08 Apr 2003)
+ 08 Apr 2003; Dean Bailey <alron@gentoo.org> horde-chora-1.2-r1 :
+ Fixed an issue that cropped up when one updates horde-chora.
*horde-chora-1.2 (03 Feb 2003)
03 Feb 2003; Dean Bailey <alron@gentoo.org> horde-chora-1.2 :
diff --git a/net-www/horde-chora/files/digest-horde-chora-1.2-r1 b/net-www/horde-chora/files/digest-horde-chora-1.2-r1
new file mode 100644
index 000000000000..52ea807111ea
--- /dev/null
+++ b/net-www/horde-chora/files/digest-horde-chora-1.2-r1
@@ -0,0 +1 @@
+MD5 27438aa6319c408d93c52e1b25536f95 chora-1.2.tar.gz 154090
diff --git a/net-www/horde-chora/horde-chora-1.2-r1.ebuild b/net-www/horde-chora/horde-chora-1.2-r1.ebuild
new file mode 100644
index 000000000000..6b6c70cde4bb
--- /dev/null
+++ b/net-www/horde-chora/horde-chora-1.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-chora/horde-chora-1.2-r1.ebuild,v 1.1 2003/04/08 21:50:17 alron Exp $
+
+DESCRIPTION="Chora ${PV} is the Horde CVS viewer."
+HOMEPAGE="http://www.horde.org"
+P=chora-1.2
+SRC_URI="ftp://ftp.horde.org/pub/chora/tarballs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.2.1
+ >=app-text/rcs-5.7-r1
+ >=dev-util/cvs-1.11.2"
+IUSE=""
+
+find_http_root() {
+ HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+ find_http_root
+
+ # detecting apache usergroup
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ dodir ${HTTPD_ROOT}/horde/chora
+ cp -r . ${D}/${HTTPD_ROOT}/horde/chora
+
+ # protecting files
+ chown -R root.${GID} ${D}/${HTTPD_ROOT}/horde/chora
+ find ${D}/${HTTPD_ROOT}/horde/chora/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/chora/ -type d -exec chmod 0750 {} \;
+}
+pkg_postinst() {
+ find_http_root
+ einfo "Please read ${HTTPD_ROOT}/horde/chora/docs/INSTALL !"
+}