summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-04 06:31:29 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-04 06:31:29 +0000
commitec92879c79b3991fae767b06010f852c2ad2dc8b (patch)
tree5ace457713e4b373602d5387386a77c8c99390a1 /net-www/links
parentdoc fix apparently left over from the previous rev. (diff)
downloadhistorical-ec92879c79b3991fae767b06010f852c2ad2dc8b.tar.gz
historical-ec92879c79b3991fae767b06010f852c2ad2dc8b.tar.bz2
historical-ec92879c79b3991fae767b06010f852c2ad2dc8b.zip
New links gpm fix; thanks eyez :)
Diffstat (limited to 'net-www/links')
-rw-r--r--net-www/links/files/digest-links-0.96-r11
-rw-r--r--net-www/links/links-0.96-r1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-www/links/files/digest-links-0.96-r1 b/net-www/links/files/digest-links-0.96-r1
new file mode 100644
index 000000000000..53ca4e30b681
--- /dev/null
+++ b/net-www/links/files/digest-links-0.96-r1
@@ -0,0 +1 @@
+MD5 1c3502f3a3a5b79312cd296fb3d60544 links-0.96.tar.gz 487424
diff --git a/net-www/links/links-0.96-r1.ebuild b/net-www/links/links-0.96-r1.ebuild
new file mode 100644
index 000000000000..d69152dd9ac6
--- /dev/null
+++ b/net-www/links/links-0.96-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Parag Mehta <pm@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/net-www/links/links-0.96.ebuild,v 1.2 2001/12/02 03:25:51 drobbins Exp
+
+S=${WORKDIR}/${P}
+SRC_URI="http://artax.karlin.mff.cuni.cz/~mikulas/links/download/${P}.tar.gz"
+HOMEPAGE="http://artax.karlin.mff.cuni.cz/~mikulas/links"
+DESCRIPTION="A console-based web browser"
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.1 gpm? ( >=sys-libs/gpm-1.19.3 ) ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+ local myconf
+ if [ "`use ssl` " ]
+ then
+ myconf="--enable-ssl"
+ else
+ myconf="--disable-ssl"
+ fi
+ ./configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man ${myconf} || die
+ # links doesn't respect a --without-gpm option; the only way to fix it is to edit the
+ # 'config.h' file afterwads. Luckily for us, sed exists. ;)
+ if [ "`use gpm`" ]
+ then
+ echo "Leaving LibGPM enabled."
+ else
+ echo "Disabling LibGPM."
+ cat config.h | sed 's/.*LIBGPM 1/#undef HAVE_LIBGPM/g' > tmp~
+ mv tmp~ config.h
+ fi
+ emake || die
+}
+
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README SITES NEWS AUTHORS COPYING BUGS TODO Changelog
+}
+
+