summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-21 13:28:44 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-21 13:28:44 +0000
commit9477a89da03ece5e63f5e8db22a539a57b7948fc (patch)
treefd48d8da28cbab6cd9fbb1fbb3885a7cfa4a336d /net-www/lynx
parentNo more gzipped HTML documentation (diff)
downloadhistorical-9477a89da03ece5e63f5e8db22a539a57b7948fc.tar.gz
historical-9477a89da03ece5e63f5e8db22a539a57b7948fc.tar.bz2
historical-9477a89da03ece5e63f5e8db22a539a57b7948fc.zip
No more gzipped HTML documentation
Diffstat (limited to 'net-www/lynx')
-rw-r--r--net-www/lynx/ChangeLog9
-rw-r--r--net-www/lynx/files/digest-lynx-2.8.4a-r31
-rw-r--r--net-www/lynx/lynx-2.8.4a-r3.ebuild54
3 files changed, 63 insertions, 1 deletions
diff --git a/net-www/lynx/ChangeLog b/net-www/lynx/ChangeLog
index 35a8ed97017f..e19bc7fe4ea0 100644
--- a/net-www/lynx/ChangeLog
+++ b/net-www/lynx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/lynx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.1 2002/02/01 21:53:36 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.2 2002/03/21 13:28:44 seemant Exp $
+
+*lynx-2.8.4a-r3 (21 Mar 2002)
+
+ 21 Mar 2002; Seemant Kulleen <seemant@gentoo.org> lynx-2.8.4a-r3.ebuild :
+
+ HTML documentation will no longer be gzipped. This bug located by
+ stefan@mdy.univie.ac.at
*lynx-2.8.4a-r2 (1 Feb 2002)
diff --git a/net-www/lynx/files/digest-lynx-2.8.4a-r3 b/net-www/lynx/files/digest-lynx-2.8.4a-r3
new file mode 100644
index 000000000000..691a54fa5b52
--- /dev/null
+++ b/net-www/lynx/files/digest-lynx-2.8.4a-r3
@@ -0,0 +1 @@
+MD5 6916c0127839f1e454052b683e4691c4 lynx2.8.4.tar.bz2 1940531
diff --git a/net-www/lynx/lynx-2.8.4a-r3.ebuild b/net-www/lynx/lynx-2.8.4a-r3.ebuild
new file mode 100644
index 000000000000..3a3e4ffc4ed9
--- /dev/null
+++ b/net-www/lynx/lynx-2.8.4a-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.4a-r3.ebuild,v 1.1 2002/03/21 13:28:44 seemant Exp $
+
+S=${WORKDIR}/lynx2-8-4
+HOMEPAGE="http://lynx.browser.org/"
+SRC_URI="ftp://lynx.isc.org/lynx/lynx2.8.4/lynx2.8.4.tar.bz2"
+
+DESCRIPTION="An excellent console-based web browser with ssl support"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+ nls? ( sys-devel/gettext )
+ ssl? ( >= dev-libs/openssl-0.9.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/lynx2.8.4rel.1a.patch || die
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf="${myconf} --enable-nls"
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share \
+ --libdir=/etc/lynx --enable-cgi-links --enable-prettysrc \
+ --enable-nsl-fork --enable-file-upload --enable-read-eta \
+ --enable-libjs --enable-color-style --enable-scrollbar \
+ --enable-included-msgs --with-zlib --host=${CHOST} ${myconf}
+ assert
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make prefix=${D}/usr datadir=${D}/usr/share mandir=${D}/usr/share/man \
+ libdir=${D}/etc/lynx install || die
+
+ dodoc CHANGES COPYHEADER COPYING INSTALLATION PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help
+
+ # small little manpage glitch
+ rm ${D}/usr/share/man/lynx.1
+ newman lynx.man lynx.1
+}