summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-28 20:34:47 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-28 20:34:47 +0000
commit7eba6dba58d33500e18b9d0b1e2362b757a76459 (patch)
treeadd73700f1963ae7c1cd34a7f1b2bea569ceb44b /net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild
parentupdated layout (diff)
downloadhistorical-7eba6dba58d33500e18b9d0b1e2362b757a76459.tar.gz
historical-7eba6dba58d33500e18b9d0b1e2362b757a76459.tar.bz2
historical-7eba6dba58d33500e18b9d0b1e2362b757a76459.zip
new Apache2 module
Diffstat (limited to 'net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild')
-rw-r--r--net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild b/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild
new file mode 100644
index 000000000000..588e76180736
--- /dev/null
+++ b/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild,v 1.1 2002/11/28 20:34:47 woodchip Exp $
+
+DESCRIPTION="A generic Apache2 credential caching module"
+HOMEPAGE="http://original.killa.net/infosec/mod_authenticache/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://original.killa.net/infosec/${PN}/${P}.tar.bz2"
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND} =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_compile() {
+ #fix version string
+ perl -pi -e "s|^#define VERSION .*|#define VERSION \"${PV}\"|g" \
+ defines.h
+ apxs2 -c ${PN}.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/28_mod_authenticache.conf
+ dodoc ${FILESDIR}/28_mod_authenticache.conf
+ newdoc ${FILESDIR}/dot-htaccess .htaccess
+ newdoc ${FILESDIR}/dot-htpasswd .htpasswd
+}