summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-05-03 12:48:24 +0000
committerChuck Short <zul@gentoo.org>2004-05-03 12:48:24 +0000
commitf1c66e0fd2b06b9d22e7b17e561dc761ad010bad (patch)
tree52cf9aed9c54712ea0e170fd72f24d857d9f7836 /net-www/mod_log_sql
parentAdded postgres to init script. (diff)
downloadhistorical-f1c66e0fd2b06b9d22e7b17e561dc761ad010bad.tar.gz
historical-f1c66e0fd2b06b9d22e7b17e561dc761ad010bad.tar.bz2
historical-f1c66e0fd2b06b9d22e7b17e561dc761ad010bad.zip
Version bump, closes #39553.
Diffstat (limited to 'net-www/mod_log_sql')
-rw-r--r--net-www/mod_log_sql/ChangeLog7
-rw-r--r--net-www/mod_log_sql/files/digest-mod_log_sql-1.971
-rw-r--r--net-www/mod_log_sql/mod_log_sql-1.97.ebuild99
3 files changed, 106 insertions, 1 deletions
diff --git a/net-www/mod_log_sql/ChangeLog b/net-www/mod_log_sql/ChangeLog
index 6fd9ca736629..c375e3203b24 100644
--- a/net-www/mod_log_sql/ChangeLog
+++ b/net-www/mod_log_sql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_log_sql
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/ChangeLog,v 1.2 2004/04/30 19:28:02 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/ChangeLog,v 1.3 2004/05/03 12:48:24 zul Exp $
+
+*mod_log_sql-1.97 (04 May 2004)
+
+ 04 May 2004; Chuck Short <zul@gentoo.org> mod_log_sql-1.97.ebuild:
+ Version bump, closes #49553.
30 Apr 2004; David Holm <dholm@gentoo.org> mod_log_sql-1.96.ebuild:
Added to ~ppc.
diff --git a/net-www/mod_log_sql/files/digest-mod_log_sql-1.97 b/net-www/mod_log_sql/files/digest-mod_log_sql-1.97
new file mode 100644
index 000000000000..8ba23f1b1fa3
--- /dev/null
+++ b/net-www/mod_log_sql/files/digest-mod_log_sql-1.97
@@ -0,0 +1 @@
+MD5 6e5616dbb6eec5e1acd2d3fd8b42e5be mod_log_sql-1.97.tar.gz 148593
diff --git a/net-www/mod_log_sql/mod_log_sql-1.97.ebuild b/net-www/mod_log_sql/mod_log_sql-1.97.ebuild
new file mode 100644
index 000000000000..82427396c390
--- /dev/null
+++ b/net-www/mod_log_sql/mod_log_sql-1.97.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/mod_log_sql-1.97.ebuild,v 1.1 2004/05/03 12:48:24 zul Exp $
+
+DESCRIPTION="An Apache module for logging to an SQL (MySQL) database"
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_log_sql/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://www.outoforder.cc/downloads/mod_log_sql/${P}.tar.gz"
+DEPEND=">=dev-db/mysql-3.23.15
+ apache2? ( =net-www/apache-2* ) : ( >=net-www/apache-1* )"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+SLOT="0"
+
+
+
+detectapache() {
+ local domsg=
+ [ -n "$1" ] && domsg=1
+ HAVE_APACHE1=
+ HAVE_APACHE2=
+ has_version '=net-www/apache-1*' && HAVE_APACHE1=1
+ has_version '=net-www/apache-2*' && HAVE_APACHE2=1
+
+ [ -n "${HAVE_APACHE1}" ] && APACHEVER=1
+ [ -n "${HAVE_APACHE2}" ] && APACHEVER=2
+ [ -n "${HAVE_APACHE1}" ] && [ -n "${HAVE_APACHE2}" ] && APACHEVER='both'
+
+ case "${APACHEVER}" in
+ 1) [ -n "${domsg}" ] && einfo 'Apache1 only detected' ;;
+ 2) [ -n "${domsg}" ] && einfo 'Apache2 only detected' ;;
+ both)
+ if [ "`use apache2`" ]; then
+ [ -n "${domsg}" ] && einfo "Multiple Apache versions detected, using Apache2 (USE=apache2)"
+ APACHEVER=2
+ else
+ [ -n "${domsg}" ] && einfo 'Multiple Apache versions detected, using Apache1 (USE=-apache2)'
+ APACHEVER=1
+ fi ;;
+ *) if [ -n "${domsg}" ]; then
+ MSG="Unknown Apache version!"; eerror $MSG ; die $MSG
+ else
+ die $MSG
+ fi; ;;
+ esac
+
+ if [ "$APACHEVER" == "2" ]; then
+ APXS="`which apxs2`"
+ APACHE_MODULES_DIR=/usr/lib/apache2-extramodules
+ CONFIG_FILE=${FILESDIR}/10_mod_log_sql_apache2.conf
+ APACHE_MODULES_CONFIG_DIR=/etc/apache2/conf/modules.d
+ else
+ APXS="`which apxs`"
+ APACHE_MODULES_DIR=/usr/lib/apache-extramodules
+ CONFIG_FILE=${FILESDIR}/10_mod_log_sql.conf
+ APACHE_MODULES_CONFIG_DIR=/etc/apache/conf/modules.d
+ fi
+}
+
+
+
+src_compile() {
+ detectapache
+ myconf="--with-apxs=${APXS}"
+
+ use ssl && myconf="${myconf} --enable-ssl"
+ ./configure ${myconf}
+ emake || die
+}
+
+src_install() {
+ detectapache
+ exeinto ${APACHE_MODULES_DIR}
+ doexe .libs/${PN}.so
+
+ use ssl && doexe .libs/mod_log_sql_ssl.so
+
+ cat ${CONFIG_FILE} | sed -e "s#machine_id#`hostname -f`#" > 10_mod_log_sql.conf
+ insinto ${APACHE_MODULES_CONFIG_DIR}
+ doins 10_mod_log_sql.conf
+
+ dodoc AUTHORS CHANGELOG INSTALL LICENSE TODO Documentation/README Documentation/manual.html Documentation/manual.xml
+ docinto contrib
+ dodoc contrib/create_tables.sql contrib/make_combined_log.pl contrib/mysql_import_combined_log.pl
+}
+
+pkg_postinst() {
+ detectapache
+ if [ "$APACHEVER" == "2" ]; then
+ einfo "Please add '-D LOG_SQL' to your /etc/conf.d/apache2 APACHE2_OPTS setting."
+ else
+ einfo "Please add '-D LOG_SQL' to your /etc/conf.d/apache APACHE_OPTS setting"
+ fi
+
+ einfo "Do not forget to adapt ${APACHE_MODULES_CONFIG_DIR}/10_mod_log_sql.conf to your needs."
+ einfo "See /usr/share/doc/${PF}/contrib/create_tables.sql.gz on how to create logging tables.\n"
+}