summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-05-30 20:23:14 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-05-30 20:23:14 +0000
commit4caf80fdb71ebbc85d673b07d2450081403092b7 (patch)
tree99a2cd8d01bb46106b59c5de48636bbd31f25ae9 /net-www/netscape-flash
parentfixed gtkmm deps (diff)
downloadhistorical-4caf80fdb71ebbc85d673b07d2450081403092b7.tar.gz
historical-4caf80fdb71ebbc85d673b07d2450081403092b7.tar.bz2
historical-4caf80fdb71ebbc85d673b07d2450081403092b7.zip
Version bump.
Diffstat (limited to 'net-www/netscape-flash')
-rw-r--r--net-www/netscape-flash/ChangeLog8
-rw-r--r--net-www/netscape-flash/Manifest4
-rw-r--r--net-www/netscape-flash/files/digest-netscape-flash-7.0.252
-rw-r--r--net-www/netscape-flash/netscape-flash-7.0.25.ebuild55
4 files changed, 67 insertions, 2 deletions
diff --git a/net-www/netscape-flash/ChangeLog b/net-www/netscape-flash/ChangeLog
index 5ecd7beefac3..5bc7f73e4093 100644
--- a/net-www/netscape-flash/ChangeLog
+++ b/net-www/netscape-flash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/netscape-flash
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.22 2004/05/13 18:08:47 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.23 2004/05/30 20:23:14 aliz Exp $
+
+*netscape-flash-7.0.25 (30 May 2004)
+
+ 30 May 2004; Daniel Ahlberg <aliz@gentoo.org> netscape-flash-7.0.25.ebuild:
+ Version bump, found by Alexandru Toma <flash3001@yahoo.com> in #52120.
+ Fix readme.txt installation, closing #51017.
13 May 2004; Daniel Ahlberg <aliz@gentoo.org> netscape-flash-6.0.81.ebuild:
x86 and amd64 unmask.
diff --git a/net-www/netscape-flash/Manifest b/net-www/netscape-flash/Manifest
index 24bfbae64da3..071d0694517f 100644
--- a/net-www/netscape-flash/Manifest
+++ b/net-www/netscape-flash/Manifest
@@ -1,5 +1,7 @@
MD5 d6fac6d01c694560928f47d192ab0685 netscape-flash-6.0.81.ebuild 1356
MD5 c00aacb90f4fa1bfbf4b7d1df2c29384 netscape-flash-6.0.79.ebuild 1205
-MD5 a351c50452977d6207a8685445278dd3 ChangeLog 3600
+MD5 1c1dd3176208bdc0a7b66305d7b145f3 netscape-flash-7.0.25.ebuild 1383
+MD5 a2f59e6e420a380f2a70e487693d2ac5 ChangeLog 3837
MD5 49a191691f09c2436f41c87d3ca8b276 files/digest-netscape-flash-6.0.79 144
MD5 553a045f5175d5cb331b737777e17cc0 files/digest-netscape-flash-6.0.81 144
+MD5 12d4887a4d1906a8d8a558f6607ad579 files/digest-netscape-flash-7.0.25 142
diff --git a/net-www/netscape-flash/files/digest-netscape-flash-7.0.25 b/net-www/netscape-flash/files/digest-netscape-flash-7.0.25
new file mode 100644
index 000000000000..93f66587b4b2
--- /dev/null
+++ b/net-www/netscape-flash/files/digest-netscape-flash-7.0.25
@@ -0,0 +1,2 @@
+MD5 79c59a5ea29347e01c8e6575dd054cd1 flash-plugin-7.0.25.tar.gz 987452
+MD5 9bf9ef915513a4ec4c7a7de179ea4a37 gflashplayer-6.0.69.tar.gz 700843
diff --git a/net-www/netscape-flash/netscape-flash-7.0.25.ebuild b/net-www/netscape-flash/netscape-flash-7.0.25.ebuild
new file mode 100644
index 000000000000..8a0d4db7fd7e
--- /dev/null
+++ b/net-www/netscape-flash/netscape-flash-7.0.25.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-7.0.25.ebuild,v 1.1 2004/05/30 20:23:14 aliz Exp $
+
+inherit nsplugins
+
+#until a new package of gflashplayer is released
+OLD_V="6.0.69"
+
+IUSE="gtk"
+
+S=${WORKDIR}/install_flash_player_7_linux
+DESCRIPTION="Macromedia Shockwave Flash Player"
+SRC_URI="mirror://macromedia/flash-plugin-${PV}.tar.gz
+ gtk? mirror://macromedia/gflashplayer-${OLD_V}.tar.gz"
+HOMEPAGE="http://www.macromedia.com/"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 -ppc -sparc"
+LICENSE="Macromedia"
+
+RDEPEND="!net-www/gplflash"
+
+DEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-xlibs )
+ !amd64? ( gtk? ( >=sys-libs/lib-compat-1.1
+ =x11-libs/gtk+-1.2* ) )"
+
+RESTRICT=nostrip
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe libflashplayer.so
+
+ insinto /opt/netscape/plugins
+ doins flashplayer.xpt
+
+ inst_plugin /opt/netscape/plugins/libflashplayer.so
+ inst_plugin /opt/netscape/plugins/flashplayer.xpt
+
+ dodoc Readme.txt
+ dohtml Readme.htm
+
+ # Optionally install the standalone GTK flash player
+ if [ "${ARCH}" != "amd64" ]; then
+ if use gtk
+ then
+ cd ${WORKDIR}/install_flash_player_6_linux_sa
+ docinto gflashplayer
+ dodoc readme.txt
+ dohtml ReadMe.htm
+ dobin gflashplayer
+ fi
+ fi
+}