summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-12-26 17:55:25 +0000
committerMamoru Komachi <usata@gentoo.org>2003-12-26 17:55:25 +0000
commit3ca6499eb687217bcb669b937d2cd164d5b93f2d (patch)
treeeb5f1a8fb552d1e39e831fd47cbe77a06dbf841d /net-www
parentFixed runtime error on ruby 1.8. Forced ruby 1.6 for gorua-0.16-r1 (diff)
downloadhistorical-3ca6499eb687217bcb669b937d2cd164d5b93f2d.tar.gz
historical-3ca6499eb687217bcb669b937d2cd164d5b93f2d.tar.bz2
historical-3ca6499eb687217bcb669b937d2cd164d5b93f2d.zip
Fixed runtime error on ruby 1.8. Forced ruby 1.6 for gorua-0.16-r1
Diffstat (limited to 'net-www')
-rw-r--r--net-www/gorua/Manifest6
-rw-r--r--net-www/gorua/files/digest-gorua-0.16-r2 (renamed from net-www/gorua/files/digest-gorua-0.16)0
-rw-r--r--net-www/gorua/files/gorua-0.16-ruby18-gentoo.diff66
-rw-r--r--net-www/gorua/gorua-0.16-r1.ebuild13
-rw-r--r--net-www/gorua/gorua-0.16-r2.ebuild (renamed from net-www/gorua/gorua-0.16.ebuild)15
5 files changed, 84 insertions, 16 deletions
diff --git a/net-www/gorua/Manifest b/net-www/gorua/Manifest
index fe5134af56d6..28b84135ff8c 100644
--- a/net-www/gorua/Manifest
+++ b/net-www/gorua/Manifest
@@ -1,7 +1,7 @@
MD5 8afe4eded45a484580ce855f24ffea2e metadata.xml 265
-MD5 3fc32da561f737c2ec2f8d0072512cef ChangeLog 1103
-MD5 05c6892158ddf85578aea04da32baa44 gorua-0.16-r2.ebuild 1604
-MD5 d53f44709d774a1fbef41cfa109f75c9 gorua-0.16-r1.ebuild 1669
+MD5 15b1b44f5e51cd36f84769351f75e445 ChangeLog 1103
+MD5 e54d061ba884c9e07b6ff6baced2808e gorua-0.16-r2.ebuild 1604
+MD5 0bdf432d2cdef636d49d08f28f34de1f gorua-0.16-r1.ebuild 1669
MD5 5e1b38dec1a20d9c201981a66f95f3ef files/goRua.sh 270
MD5 53b8638851a014644ff509a1059b27a2 files/gorua-bbsmenu-update-gentoo.diff 372
MD5 73ea25f0872db7674096178985e51955 files/digest-gorua-0.16-r2 62
diff --git a/net-www/gorua/files/digest-gorua-0.16 b/net-www/gorua/files/digest-gorua-0.16-r2
index f836f7dfff82..f836f7dfff82 100644
--- a/net-www/gorua/files/digest-gorua-0.16
+++ b/net-www/gorua/files/digest-gorua-0.16-r2
diff --git a/net-www/gorua/files/gorua-0.16-ruby18-gentoo.diff b/net-www/gorua/files/gorua-0.16-ruby18-gentoo.diff
new file mode 100644
index 000000000000..80c5eb0b024b
--- /dev/null
+++ b/net-www/gorua/files/gorua-0.16-ruby18-gentoo.diff
@@ -0,0 +1,66 @@
+--- goRua.rb.orig 2003-12-10 10:34:27.000000000 +0900
++++ goRua.rb 2003-11-08 08:28:35.000000000 +0900
+@@ -1486,7 +1457,16 @@
+ end
+ end
+
+-
++class ViewNotebook < Gtk::Notebook
++ def remove_page(num)
++ page = get_nth_page(num)
++ begin
++ page.get_thread.close_file
++ rescue NameError
++ end
++ super(num)
++ end
++end
+
+ #Threadの内容を見るBox
+ class ViewVBox < Gtk::VBox
+@@ -1617,7 +1606,8 @@
+
+
+ # ノートブック
+- @notebook = Gtk::Notebook::new()
++# @notebook = Gtk::Notebook::new()
++ @notebook = ViewNotebook::new()
+
+ @notebook.set_usize VIEW_WIDTH2, HEIGHT3
+ # ? `requisition=': wrong # of arguments(1 for 2) (ArgumentError)
+@@ -2670,7 +2670,7 @@
+ self.set_subtree subtree
+ # i=0
+ array.each{ |thread|
+- thread_item = Gtk::ThreadTreeItem.new(thread,self,false)
++ thread_item = ThreadTreeItem.new(thread,self,false)
+ subtree.append thread_item
+ thread_item.show_all
+ # i+=1
+@@ -2778,7 +2778,7 @@
+ thread = ThreadShitaraba.new(unquote(title),url,thread,@board.get_dat)
+ end
+ @board.append_thread thread
+- thread_item = Gtk::ThreadTreeItem.new(thread,self)
++ thread_item = ThreadTreeItem.new(thread,self)
+ subtree.append thread_item
+ thread_item.show
+ while Gtk.events_pending
+@@ -3126,7 +3120,7 @@
+ hash.each{ |board|
+ @tree_size+=1
+
+- item = Gtk::BoardTreeItem.new(board)
++ item = BoardTreeItem.new(board)
+ @tree.append item
+ array = board.get_thread_array
+ if array != []
+@@ -3134,7 +3128,7 @@
+ item.set_subtree subtree
+ i=0
+ array.each{ |thread|
+- thread_item = Gtk::ThreadTreeItem.new(thread,item)
++ thread_item = ThreadTreeItem.new(thread,item)
+ subtree.append thread_item
+ thread_item.show_all
+ i+=1
diff --git a/net-www/gorua/gorua-0.16-r1.ebuild b/net-www/gorua/gorua-0.16-r1.ebuild
index c20b17ab8c7f..2b4bc972164b 100644
--- a/net-www/gorua/gorua-0.16-r1.ebuild
+++ b/net-www/gorua/gorua-0.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gorua/gorua-0.16-r1.ebuild,v 1.1 2003/10/12 20:21:45 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gorua/gorua-0.16-r1.ebuild,v 1.2 2003/12/26 17:55:16 usata Exp $
IUSE=""
@@ -12,9 +12,9 @@ SRC_URI="http://www.unixuser.org/~haruyama/software/goRua/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~alpha ~ppc ~sparc"
+KEYWORDS="x86 alpha ppc sparc"
-DEPEND=">=dev-lang/ruby-1.6.8
+DEPEND="=dev-lang/ruby-1.6*
=x11-libs/gtk+-1.2*
>=dev-ruby/ruby-gtk-0.28
>=media-fonts/monafont-2.22
@@ -41,8 +41,11 @@ src_compile() {
src_install() {
local sitedir=`ruby -r rbconfig -e 'print Config::CONFIG["sitedir"]'`
- exeinto /usr/bin
- doexe ${T}/goRua.rb ${T}/goRua
+ dobin ${T}/goRua.rb ${T}/goRua
+
+ if has_version '>=dev-lang/ruby-1.6.8-r2' ; then
+ dosed -e "s:/usr/bin/env ruby:/usr/bin/ruby16:g" /usr/bin/goRua.rb
+ fi
insinto ${sitedir}
doins connect2ch.rb goRua_color_table.rb
diff --git a/net-www/gorua/gorua-0.16.ebuild b/net-www/gorua/gorua-0.16-r2.ebuild
index 8a01497f133c..f01c94852fec 100644
--- a/net-www/gorua/gorua-0.16.ebuild
+++ b/net-www/gorua/gorua-0.16-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gorua/gorua-0.16.ebuild,v 1.3 2003/10/12 20:21:45 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gorua/gorua-0.16-r2.ebuild,v 1.1 2003/12/26 17:55:16 usata Exp $
IUSE=""
@@ -12,11 +12,9 @@ SRC_URI="http://www.unixuser.org/~haruyama/software/goRua/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 alpha ppc sparc"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc"
DEPEND=">=dev-lang/ruby-1.6.8
- sys-apps/sed"
-DEPEND=">=dev-lang/ruby-1.6.8
=x11-libs/gtk+-1.2*
>=dev-ruby/ruby-gtk-0.28
>=media-fonts/monafont-2.22
@@ -27,7 +25,9 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/gorua-bbsmenu-update-gentoo.diff
+ epatch ${FILESDIR}/${P}-ruby18-gentoo.diff
}
src_compile() {
@@ -42,11 +42,10 @@ src_compile() {
src_install() {
- local sitelibdir=`ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]'`
- exeinto /usr/bin
- doexe ${T}/goRua.rb ${T}/goRua
+ local sitedir=`ruby -r rbconfig -e 'print Config::CONFIG["sitedir"]'`
+ dobin ${T}/goRua.rb ${T}/goRua
- insinto ${sitelibdir}
+ insinto ${sitedir}
doins connect2ch.rb goRua_color_table.rb
exeinto /usr/share/${PF}