summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-11-02 07:33:21 +0000
committerTorsten Veller <tove@gentoo.org>2008-11-02 07:33:21 +0000
commita72217c86ad3eeb21ae6bfa1b36356833c986e4d (patch)
treeb761c703346442ae19874adf40129c6eae513324 /perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.005.ebuild
parentCleanup ebuild and add ppc64 love for KDE 4. (diff)
downloadhistorical-a72217c86ad3eeb21ae6bfa1b36356833c986e4d.tar.gz
historical-a72217c86ad3eeb21ae6bfa1b36356833c986e4d.tar.bz2
historical-a72217c86ad3eeb21ae6bfa1b36356833c986e4d.zip
dev-perl => perl-core migration
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-tuxonice i686
Diffstat (limited to 'perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.005.ebuild')
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.005.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.005.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.005.ebuild
new file mode 100644
index 000000000000..92f1f35a7780
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.005.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.005.ebuild,v 1.1 2008/11/02 07:17:55 tove Exp $
+
+inherit perl-module multilib
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+HOMEPAGE="http://search.cpan.org/~pmqs"
+SRC_URI="mirror://cpan/authors/id/P/PM/PMQS/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ sys-libs/zlib"
+
+DEPEND=${RDEPEND}
+
+SRC_TEST="do"
+
+src_unpack() {
+ perl-module_src_unpack
+
+ cat - > "${S}/config.in" <<EOF
+BUILD_ZLIB = False
+INCLUDE = /usr/include
+LIB = /usr/${get_libdir}
+
+OLD_ZLIB = False
+GZIP_OS_CODE = AUTO_DETECT
+EOF
+}