summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-10-25 16:01:19 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-10-25 16:01:19 +0000
commitc20bcc32b91b2e7cba6fa6801cf7127c529174bf (patch)
treefba6dab6df6fee468ef05c271051565e8fdd7781 /sci-astronomy/orsa/orsa-0.6.1.ebuild
parentStable on sparc (diff)
downloadhistorical-c20bcc32b91b2e7cba6fa6801cf7127c529174bf.tar.gz
historical-c20bcc32b91b2e7cba6fa6801cf7127c529174bf.tar.bz2
historical-c20bcc32b91b2e7cba6fa6801cf7127c529174bf.zip
Fixed compile problems with gcc4 and as-needed LDFLAG (closes bug #152422).
Package-Manager: portage-2.1.2_pre3-r7
Diffstat (limited to 'sci-astronomy/orsa/orsa-0.6.1.ebuild')
-rw-r--r--sci-astronomy/orsa/orsa-0.6.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-astronomy/orsa/orsa-0.6.1.ebuild b/sci-astronomy/orsa/orsa-0.6.1.ebuild
index 81fb88e86017..8fd806d6ab46 100644
--- a/sci-astronomy/orsa/orsa-0.6.1.ebuild
+++ b/sci-astronomy/orsa/orsa-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/orsa/orsa-0.6.1.ebuild,v 1.8 2006/06/23 23:59:31 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/orsa/orsa-0.6.1.ebuild,v 1.9 2006/10/25 16:01:19 markusle Exp $
inherit base flag-o-matic qt3
@@ -28,6 +28,13 @@ replace-flags k6-3 i586
replace-flags k6-2 i586
replace-flags k6 i586
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_compile() {
if ! use mpi; then
export MPICXX="g++"
@@ -60,7 +67,7 @@ src_compile() {
}
src_install() {
- einstall || die
+ make install DESTDIR=${D} || die "install failed"
dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
dodoc src/test/*
}