summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-28 16:32:18 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-28 16:32:18 +0000
commit5cf40543a0c4945be09d34f0f99884c68c097d36 (patch)
tree3e02290500266e485492928113e9761c5f0e4924 /sci-astronomy/stiff
parentVersion bump (diff)
downloadhistorical-5cf40543a0c4945be09d34f0f99884c68c097d36.tar.gz
historical-5cf40543a0c4945be09d34f0f99884c68c097d36.tar.bz2
historical-5cf40543a0c4945be09d34f0f99884c68c097d36.zip
Version bump
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'sci-astronomy/stiff')
-rw-r--r--sci-astronomy/stiff/files/stiff-configure.patch63
-rw-r--r--sci-astronomy/stiff/stiff-1.12.ebuild6
2 files changed, 65 insertions, 4 deletions
diff --git a/sci-astronomy/stiff/files/stiff-configure.patch b/sci-astronomy/stiff/files/stiff-configure.patch
new file mode 100644
index 000000000000..15b8d9aa3010
--- /dev/null
+++ b/sci-astronomy/stiff/files/stiff-configure.patch
@@ -0,0 +1,63 @@
+--- configure.ac.orig 2009-03-10 12:34:36.000000000 +0000
++++ configure.ac 2009-07-28 17:26:22.000000000 +0100
+@@ -21,40 +21,14 @@
+
+ # Include macros
+ #sinclude(acx_pthread.m4)
+-sinclude(acx_prog_cc_optim.m4)
+
+ # Display pakage and version number
+ AC_MSG_RESULT([*********** Configuring: $PACKAGE $VERSION ($date) **********])
+
+-# Initialize the list of compilers to consider
+-cclist="cc gcc"
+-
+-# Backup and reset the input CFLAGS and LDFLAGS
+-mycflags="$CFLAGS"
+-CFLAGS=""
+-myldflags="$LDFLAGS"
+-LDFLAGS=""
+-
+-# Provide special option for the Linux Intel C compiler
+-AC_MSG_CHECKING([for Linux Intel C compiler mode])
+-AC_ARG_ENABLE(icc,
+- [AC_HELP_STRING([--enable-icc],
+- [Enable special mode for compilation with the Intel compiler \
+-(off by default)])],
+- use_icc="yes"
+- cclist="icc $cclist"
+- AC_MSG_RESULT([yes]),
+- use_icc="no"
+- AC_MSG_RESULT([no]))
+-
+-# Checks for programs.
+-# GCC is chosen last because it is likely to yield less optimized code
+-AC_PROG_CC([$cclist])
+ # C Compiler: Check that it is ANSI C
+ AM_PROG_CC_STDC
+ # C Compiler: Check that it is POSIX-compliant
+ AC_ISC_POSIX
+-ACX_PROG_CC_OPTIM
+ AC_PROG_AWK
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+@@ -107,19 +81,9 @@
+
+ # Link with gprof option
+ if test "$use_gprof" = "yes"; then
+- if test "$use_icc" = "yes"; then
+- CFLAGS="$CFLAGS -pq"
+- else
+- CFLAGS="$CFLAGS -pg"
+- fi
+ use_static="no"
+ fi
+
+-# Static linking option
+-if test "$use_static" = "yes"; then
+- LDFLAGS="-static -shared-libgcc $LDFLAGS"
+-fi
+-
+ # Override automatic CFLAGS and LDFLAGS with those of user
+ #if test -n "$mycflags"; then
+ #CFLAGS="$mycflags"
diff --git a/sci-astronomy/stiff/stiff-1.12.ebuild b/sci-astronomy/stiff/stiff-1.12.ebuild
index 75bdb42450cb..1716099022a0 100644
--- a/sci-astronomy/stiff/stiff-1.12.ebuild
+++ b/sci-astronomy/stiff/stiff-1.12.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stiff/stiff-1.12.ebuild,v 1.1 2009/07/28 16:31:19 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stiff/stiff-1.12.ebuild,v 1.2 2009/07/28 16:32:18 bicatali Exp $
EAPI=2
inherit autotools eutils
-DESCRIPTION="Converts astronomical FITS images to the TIFF format for illustration purposes."
+DESCRIPTION="Converts astronomical FITS images to the TIFF format"
HOMEPAGE="http://astromatic.iap.fr/software/stiff"
SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
@@ -13,14 +13,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND=""
src_prepare() {
epatch "${FILESDIR}"/${PN}-configure.patch
eautoreconf
}
-
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS BUGS ChangeLog HISTORY README THANKS