summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-02-21 20:27:27 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-02-21 20:27:27 +0000
commit9c968907d506dee6b5102faacb222b9d5a242941 (patch)
treee834ec606a70809837c9a0c4e4c634807e8347f4 /sci-biology/probcons/probcons-1.10.ebuild
parentcleaned up last v2 ebuild for fcitx (diff)
downloadhistorical-9c968907d506dee6b5102faacb222b9d5a242941.tar.gz
historical-9c968907d506dee6b5102faacb222b9d5a242941.tar.bz2
historical-9c968907d506dee6b5102faacb222b9d5a242941.zip
New multiple sequence alignment package. Probably the best global aligner, although it runs slower. Takes 5-10 times longer than clustalw, but about half as long as t-coffee.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'sci-biology/probcons/probcons-1.10.ebuild')
-rw-r--r--sci-biology/probcons/probcons-1.10.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/probcons/probcons-1.10.ebuild b/sci-biology/probcons/probcons-1.10.ebuild
new file mode 100644
index 000000000000..2128a8505739
--- /dev/null
+++ b/sci-biology/probcons/probcons-1.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/probcons-1.10.ebuild,v 1.1 2006/02/21 20:27:27 spyderous Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}_v${PV/./_}"
+DESCRIPTION="Probabilistic Consistency-based Multiple Alignment of Amino Acid Sequences"
+HOMEPAGE="http://probcons.stanford.edu/"
+SRC_URI="http://probcons.stanford.edu/${MY_P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+# Gnuplot is explicitly runtime-only, it's run using system()
+RDEPEND="sci-visualization/gnuplot"
+DEPEND=""
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-fix-cxxflags.patch
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ OPT_CXXFLAGS="${CXXFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ DESTTREE="/usr" dobin probcons project makegnuplot
+ # Overlap with imagemagick
+ DESTTREE="/usr" newbin compare compare-probcons
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "The 'compare' binary is installed as 'compare-probcons'"
+ ewarn "to avoid overlap with other packages."
+ einfo "You may also want to download the user manual"
+ einfo "from http://probcons.stanford.edu/manual.pdf"
+}