summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-01-25 04:19:24 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-01-25 04:19:24 +0000
commit4731b1a952fc66ee5cebc6f1d338d178314c496b (patch)
tree10e44a266c0231c94c8885064bd16833987df32a /sci-biology/staden
parentarm/hppa/ia64/s390/sh/x86 stable (diff)
downloadhistorical-4731b1a952fc66ee5cebc6f1d338d178314c496b.tar.gz
historical-4731b1a952fc66ee5cebc6f1d338d178314c496b.tar.bz2
historical-4731b1a952fc66ee5cebc6f1d338d178314c496b.zip
GCC 3.4 fix
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'sci-biology/staden')
-rw-r--r--sci-biology/staden/ChangeLog6
-rw-r--r--sci-biology/staden/Manifest5
-rw-r--r--sci-biology/staden/files/staden-1.5.3-mutlib-gcc-3.4.patch190
-rw-r--r--sci-biology/staden/staden-1.5.3.ebuild3
4 files changed, 200 insertions, 4 deletions
diff --git a/sci-biology/staden/ChangeLog b/sci-biology/staden/ChangeLog
index 3850740444be..233cc1793ebe 100644
--- a/sci-biology/staden/ChangeLog
+++ b/sci-biology/staden/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/staden
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/staden/ChangeLog,v 1.8 2005/01/18 00:18:29 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/staden/ChangeLog,v 1.9 2005/01/25 04:19:24 ribosome Exp $
+
+ 24 Jan 2005; Olivier Fisette <ribosome@gentoo.org>
+ +files/staden-1.5.3-mutlib-gcc-3.4.patch, staden-1.5.3.ebuild:
+ Fixed GCC 3.4 oddity.
17 Jan 2005; Olivier Fisette <ribosome@gentoo.org>
+files/staden-1.5.3-mutscan.patch, +files/staden-1.5.3-prefinish.patch,
diff --git a/sci-biology/staden/Manifest b/sci-biology/staden/Manifest
index 92a85cc24430..74ea884017d4 100644
--- a/sci-biology/staden/Manifest
+++ b/sci-biology/staden/Manifest
@@ -1,6 +1,6 @@
-MD5 269f8f498bc1c0fb2ec9d33bd2ee7623 staden-1.5.3.ebuild 10023
+MD5 35eac01b4e2df807dff698c633982530 staden-1.5.3.ebuild 10069
MD5 fe19fbd7368ca77e37fab8ee461dddda staden-1.4.1-r7.ebuild 9894
-MD5 104405704662a5eaaef1121e34bfd1c1 ChangeLog 3786
+MD5 7abc1ac30ae08fd3ed6f23aaddf2adae ChangeLog 3929
MD5 f189a3c4ff5ae55bcee4f8ed0ace5d20 metadata.xml 254
MD5 6ce4d77a48d0377a1ada09f1990fb2af files/staden-1.5.3-text_utils.patch 478
MD5 e908bf4692dd3494ec22f07db2e7a9f5 files/staden-1.4.1-env 225
@@ -12,6 +12,7 @@ MD5 2d495d394e31807f84859f854024b3fc files/staden-1.5.3-mutscan.patch 330
MD5 8650f58c55b83838846447c89543255d files/staden-1.4.1-getopt.patch 375
MD5 690ec96f38a668c6cda216d7a3960ecf files/staden-1.5.3-tracediff.patch 334
MD5 0857e0bf79953bfa46b1224f6218701a files/staden-1.5.3-top.patch 230
+MD5 82a31125cf882d95d15578040add39c3 files/staden-1.5.3-mutlib-gcc-3.4.patch 5460
MD5 7717f77ecd800d0b3049974db3fcd0a9 files/staden-1.4.1-prefinish.patch 362
MD5 daf40c222b80ffc48d9a2ac2544ab631 files/staden-1.5.3-getopt.patch 367
MD5 9f05ecafdd38d17d8dd40ff581dda1a2 files/staden-1.5.3-prefinish.patch 362
diff --git a/sci-biology/staden/files/staden-1.5.3-mutlib-gcc-3.4.patch b/sci-biology/staden/files/staden-1.5.3-mutlib-gcc-3.4.patch
new file mode 100644
index 000000000000..1d33096e3d0f
--- /dev/null
+++ b/sci-biology/staden/files/staden-1.5.3-mutlib-gcc-3.4.patch
@@ -0,0 +1,190 @@
+--- src/mutlib/array.hpp.old 2004-11-09 04:53:27.000000000 -0500
++++ src/mutlib/array.hpp 2005-01-24 21:59:12.639686328 -0500
+@@ -316,12 +316,12 @@
+ template <typename T>
+ double NumericArray<T>::Mean() const
+ {
+- assert(m_pArray != NULL);
++ assert(this->m_pArray != NULL);
+ double acc = 0.0;
+- for( int n=m_nLowerLimit; n<=m_nUpperLimit; n++ )
+- acc += m_pArray[n];
+- return (m_nUpperLimit-m_nLowerLimit+1)
+- ? acc / (m_nUpperLimit-m_nLowerLimit+1)
++ for( int n=this->m_nLowerLimit; n<=this->m_nUpperLimit; n++ )
++ acc += this->m_pArray[n];
++ return (this->m_nUpperLimit - this->m_nLowerLimit+1)
++ ? acc / (this->m_nUpperLimit - this->m_nLowerLimit+1)
+ : 0;
+ }
+
+@@ -334,18 +334,18 @@
+ template <typename T>
+ double NumericArray<T>::Variance( double* nMean ) const
+ {
+- assert(m_pArray != NULL);
++ assert(this->m_pArray != NULL);
+ double tmp;
+ double acc = 0.0;
+ double mean = nMean ? *nMean : Mean();
+- for( int n=m_nLowerLimit; n<=m_nUpperLimit; n++ )
++ for( int n=this->m_nLowerLimit; n<=this->m_nUpperLimit; n++ )
+ {
+- tmp = double(m_pArray[n]) - mean;
++ tmp = double(this->m_pArray[n]) - mean;
+ tmp *= tmp;
+ acc += tmp;
+ }
+- assert(m_nUpperLimit-m_nLowerLimit!=0);
+- return acc / static_cast<double>(m_nUpperLimit-m_nLowerLimit);
++ assert(this->m_nUpperLimit - this->m_nLowerLimit!=0);
++ return acc / static_cast<double>(this->m_nUpperLimit - this->m_nLowerLimit);
+ }
+
+
+@@ -358,10 +358,10 @@
+ T NumericArray<T>::Min() const
+ {
+ T minval = std::numeric_limits<T>::max();
+- for( int n=m_nLowerLimit; n<=m_nUpperLimit; n++ )
++ for( int n=this->m_nLowerLimit; n<=this->m_nUpperLimit; n++ )
+ {
+- if( m_pArray[n] < minval )
+- minval = m_pArray[n];
++ if( this->m_pArray[n] < minval )
++ minval = this->m_pArray[n];
+ }
+ return minval;
+ }
+@@ -376,10 +376,10 @@
+ T NumericArray<T>::Max() const
+ {
+ T maxval = std::numeric_limits<T>::min();
+- for( int n=m_nLowerLimit; n<=m_nUpperLimit; n++ )
++ for( int n=this->m_nLowerLimit; n<=this->m_nUpperLimit; n++ )
+ {
+- if( m_pArray[n] > maxval )
+- maxval = m_pArray[n];
++ if( this->m_pArray[n] > maxval )
++ maxval = this->m_pArray[n];
+ }
+ return maxval;
+ }
+@@ -392,14 +392,14 @@
+ // Linear interpolation between two points using equation y = mx + c
+ assert(x1<x2);
+ assert(x1>=0);
+- assert(x2<m_nLength);
++ assert(x2<this->m_nLength);
+ if( x2 > x1 )
+ {
+ int points = x2 - x1;
+- T c = m_pArray[x1];
+- double m = static_cast<double>(m_pArray[x2] - m_pArray[x1]) / static_cast<double>(points);
++ T c = this->m_pArray[x1];
++ double m = static_cast<double>(this->m_pArray[x2] - this->m_pArray[x1]) / static_cast<double>(points);
+ for( int x=0; x<points; x++, x1++ )
+- m_pArray[x1] = static_cast<T>( m*x + c );
++ this->m_pArray[x1] = static_cast<T>( m*x + c );
+ }
+ }
+
+@@ -436,8 +436,8 @@
+ bool DNAArray<CharT>::IsACGT( int nBasePos ) const
+ {
+ assert(nBasePos>=0);
+- assert(nBasePos<m_nLength);
+- switch( m_pArray[nBasePos] )
++ assert(nBasePos<this->m_nLength);
++ switch( this->m_pArray[nBasePos] )
+ {
+ case 'A':
+ case 'C':
+@@ -467,11 +467,11 @@
+ Base numbers are assumed to be zero-based.
+ */
+ assert(nBasePos>=0);
+- assert(nBasePos<m_nLength);
++ assert(nBasePos<this->m_nLength);
+ int bp = 0;
+- for( int n=0; n<m_nLength; n++ )
++ for( int n=0; n<this->m_nLength; n++ )
+ {
+- if( m_pArray[n] == cPad )
++ if( this->m_pArray[n] == cPad )
+ continue;
+ if( bp == nBasePos )
+ return n;
+@@ -493,9 +493,9 @@
+ Counts the number of pad characters contained in the current range.
+ */
+ int nPads = 0;
+- for( int n=m_nLowerLimit; n<=m_nUpperLimit; n++ )
++ for( int n=this->m_nLowerLimit; n<=this->m_nUpperLimit; n++ )
+ {
+- if( m_pArray[n] == cPad )
++ if( this->m_pArray[n] == cPad )
+ nPads++;
+ }
+ return nPads;
+@@ -519,9 +519,9 @@
+ {
+ // Scan from left
+ i = 0;
+- while( (i<m_nLength) && (n>0) )
++ while( (i<this->m_nLength) && (n>0) )
+ {
+- if( m_pArray[i] != cPad )
++ if( this->m_pArray[i] != cPad )
+ n--;
+ i++;
+ }
+@@ -529,10 +529,10 @@
+ else
+ {
+ // Scan from right
+- i = m_nLength - 1;
++ i = this->m_nLength - 1;
+ while( (i>=0) && (n>0) )
+ {
+- if( m_pArray[i] != cPad )
++ if( this->m_pArray[i] != cPad )
+ n--;
+ i--;
+ }
+@@ -546,12 +546,12 @@
+ int DNAArray<CharT>::GetOriginalPosition( int i, bool bLeft, char cPad ) const
+ {
+ assert(i>=0);
+- assert(i<m_nLength);
++ assert(i<this->m_nLength);
+
+
+ // Check input
+ int n = -1;
+- if( i >= m_nLength )
++ if( i >= this->m_nLength )
+ return n;
+
+
+@@ -561,7 +561,7 @@
+ // Scan to left
+ while( i >= 0 )
+ {
+- if( m_pArray[i] != cPad )
++ if( this->m_pArray[i] != cPad )
+ n++;
+ i--;
+ }
+@@ -569,9 +569,9 @@
+ else
+ {
+ // Scan to right
+- while( i < m_nLength )
++ while( i < this->m_nLength )
+ {
+- if( m_pArray[i] != cPad )
++ if( this->m_pArray[i] != cPad )
+ n++;
+ i++;
+ }
diff --git a/sci-biology/staden/staden-1.5.3.ebuild b/sci-biology/staden/staden-1.5.3.ebuild
index f92e65b1c732..0d0a5891b7fc 100644
--- a/sci-biology/staden/staden-1.5.3.ebuild
+++ b/sci-biology/staden/staden-1.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/staden/staden-1.5.3.ebuild,v 1.2 2005/01/18 00:18:29 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/staden/staden-1.5.3.ebuild,v 1.3 2005/01/25 04:19:24 ribosome Exp $
inherit eutils toolchain-funcs
@@ -73,6 +73,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-prefinish.patch
epatch ${FILESDIR}/${P}-tracediff.patch
epatch ${FILESDIR}/${P}-mutscan.patch
+ epatch ${FILESDIR}/${P}-mutlib-gcc-3.4.patch
cd ${S}/src/mk
# Remove the "-fpic" flag. This will be replaced by "-fPIC".
sed -i -e 's/SHLIB_CFLAGS = -fpic/SHLIB_CFLAGS = /' linux.mk