summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-05-13 01:54:59 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-05-13 01:54:59 +0000
commit5531a875d9d1e4512a5f568a29a56262da28cd4b (patch)
tree89b8440455428eae3ed903309da6841f31948c0a /sci-biology
parentmake sure dev-games/guichan is built with USE=sdl #92362 (diff)
downloadhistorical-5531a875d9d1e4512a5f568a29a56262da28cd4b.tar.gz
historical-5531a875d9d1e4512a5f568a29a56262da28cd4b.tar.bz2
historical-5531a875d9d1e4512a5f568a29a56262da28cd4b.zip
New version
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/qrna/ChangeLog9
-rw-r--r--sci-biology/qrna/Manifest14
-rw-r--r--sci-biology/qrna/files/digest-qrna-2.0.3b1
-rw-r--r--sci-biology/qrna/qrna-2.0.3b.ebuild55
4 files changed, 66 insertions, 13 deletions
diff --git a/sci-biology/qrna/ChangeLog b/sci-biology/qrna/ChangeLog
index 04bc086cd37d..c4ad22e9d52f 100644
--- a/sci-biology/qrna/ChangeLog
+++ b/sci-biology/qrna/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/qrna
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/qrna/ChangeLog,v 1.3 2004/12/23 18:24:03 swegener Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/qrna/ChangeLog,v 1.4 2005/05/13 01:54:59 ribosome Exp $
+
+*qrna-2.0.3b (13 May 2005)
+
+ 13 May 2005; Olivier Fisette <ribosome@gentoo.org> +qrna-2.0.3b.ebuild:
+ New version.
*qrna-2.0.2c (23 Dec 2004)
diff --git a/sci-biology/qrna/Manifest b/sci-biology/qrna/Manifest
index 6ebef5072ab5..180c8726a593 100644
--- a/sci-biology/qrna/Manifest
+++ b/sci-biology/qrna/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 39b495aeaa79d837eafe1b311eae4a99 qrna-2.0.3b.ebuild 1327
MD5 6ccfb9d7cf660b0dc339d5ef8c9f85cc qrna-2.0.2c.ebuild 897
-MD5 b6ed2372ef5df30d362a597ea613457e ChangeLog 937
+MD5 393bbffcac028e8358b84673f8fc2532 ChangeLog 1055
MD5 f189a3c4ff5ae55bcee4f8ed0ace5d20 metadata.xml 254
MD5 9127b0a4628230fc3bf2e201ca7519a9 files/26qrna 30
MD5 23a5277d2c657c4624bc93b197c51020 files/digest-qrna-2.0.2c 57
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFByw1JI1lqEGTUzyQRAvmMAKCOhk6e1JtupKOvNqSPSinIaH9ljQCfZYWP
-4CZs8JDQw0cjEdPP0olZNr0=
-=BY3L
------END PGP SIGNATURE-----
+MD5 37c729a337a1eba6eda00b69f3d5f608 files/digest-qrna-2.0.3b 65
diff --git a/sci-biology/qrna/files/digest-qrna-2.0.3b b/sci-biology/qrna/files/digest-qrna-2.0.3b
new file mode 100644
index 000000000000..43177b62e6db
--- /dev/null
+++ b/sci-biology/qrna/files/digest-qrna-2.0.3b
@@ -0,0 +1 @@
+MD5 4258ab809070c2e6fe10a262b95f24ba qrna-2.0.3b.tar.bz2 8988306
diff --git a/sci-biology/qrna/qrna-2.0.3b.ebuild b/sci-biology/qrna/qrna-2.0.3b.ebuild
new file mode 100644
index 000000000000..ff596d6b2be7
--- /dev/null
+++ b/sci-biology/qrna/qrna-2.0.3b.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/qrna/qrna-2.0.3b.ebuild,v 1.1 2005/05/13 01:54:59 ribosome Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Prototype ncRNA genefinder"
+HOMEPAGE="http://www.genetics.wustl.edu/eddy/software/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ virtual/libc"
+
+src_compile () {
+ sed -e "s/CC = gcc/CC = $(tc-getCC)/" \
+ -e "s/CFLAGS = -O/CFLAGS = ${CFLAGS}/" \
+ -i src/Makefile squid/Makefile
+ sed -e "s/CC = gcc/CC = $(tc-getCC)/" \
+ -e "s/CFLAGS = -g -O2/CFLAGS = ${CFLAGS}/" \
+ -i squid02/Makefile
+ cd ${S}/squid
+ emake || die
+ cd ${S}/squid02
+ emake || die
+ cd ${S}/src
+ emake || die
+}
+
+src_install () {
+ cd ${S}/src
+ dobin cfgbuild eqrna eqrna_sample main rnamat_main shuffle
+ cd ${S}/squid02
+ dobin afetch alistat compalign compstruct revcomp seqsplit seqstat \
+ sfetch shuffle sindex sreformat translate weight
+ cd ${S}
+ dobin scripts/*
+
+ newdoc 00README
+ insinto /usr/share/doc/${PF}
+ doins documentation/*
+
+ insinto /usr/share/${PN}/data
+ doins lib/*
+ insinto /usr/share/${PN}/demos
+ doins Demos/*
+
+ # Sets the path to the QRNA data files.
+ insinto /etc/env.d
+ doins ${FILESDIR}/26qrna
+}